THERION POUR LES SPELEOS PURS ET DURS (MAIS TOPOGRAPHES QUAND MEME !)

INDEX

1-INTRODUCTION

2- COMMENT CA MARCHE ?

  • 2.1- Généralités
  • 2.2- Données LRUD (en français : GDHB pour Gauche, Droite, Haut, Bas)
  • 2.3- Therion et XTherion
  • 2.4- Comment l'installer

3- LA BALLADE DES DAMES DU TEMPS JADIS

  • 3.1- Le plan
  • 3.2- Coupe développée
  • 3.3- Sections transversales
  • 3.4- Le pdf final (enfin !!!)

4- LES CHOSES DIFFICILES…

  • 4.1- Joindre des lignes d'axe topographique
  • 4.2- Joindre des Scraps
  • 4.3- Régler l'ajustement (on utilisera layout par la suite !)

1- INTRODUCTION

Therion est la prochaine étape des logiciels de topographie spéléologique. Il fonctionne sous Windows (9X, 2000 XP), *nix et MacOS X. Il est sous licence GNU-GPL.

Traditionnellement, un logiciel de topographie spéléologique travaille avec les seules données métriques (de, vers, longueur, direction, pente,…). A partir de ces données, une ligne d'axe (centerline) est calculée, puis cette ligne est exportée vers un logiciel de dessin comme Illustrator, où l'on ajoute les parois et autres détails.

Therion peut travailler à la fois avec les données métriques et les dessins. Il n'est plus utile d'exporter la ligne d'axe vers un logiciel de dessin. Vous pouvez dessiner une ligne représentant un puits, puis définir son type comme puits et Therion dessinera un puits en utilisant les normes de l'UIS ou d'autres groupes spéléologiques. Donc vous n'avez plus besoin de casser le copyright très restrictif d'Illustrator pour réaliser cela !

Therion peut déformer vos dessins pour les adapter aux changements de votre ligne d'axe.Si les données de votre ligne d'axe sont modifiées, habituellement, vous devez redessiner les parois, … Ce n'est pas utile avec Therion. Ses algorithmes tiennent compte de choses comme les superpositions de passages, etc… Ainsi, vos relevés sont toujours à jour ! Vous n'avez pas besoin de redessiner après avoir réalisé une boucle, corrigé une bourde, ou changer de lot de symboles.

Therion peut dessiner des plans sur une seule page, dans la limite de 5 X 5 mètres. Il peut également dessiner des atlas de cavité, avec zone de recouvrement et icône de navigation sur chaque page.

Therion peut construire des modèles 3D avec les données LRUD, Ces modèles sont calculés à partir des parois que vous dessinez, ainsi les modèles 3D de Therion paraissent normalement meilleurs que les modèles 3D “carrés” calculés par les autres logiciels de topographie souterraine. Les données de surface peuvent être ajoutés.

Enfin, Therion peut exporter vos données de ligne d'axe au format SQL, prêtes à être récupérées dans une base de données, vous permettant ainsi de réaliser des recherches complètes sur ces données, ou les intégrer dans SIG.

Ce guide suppose que vous n'êtes pas un “geek”-spéléologue, c'est-à-dire un spéléo pro de l'informatique, mais un vrai spéléo avec peu, voire pas de connaissances en informatique. Si vous êtes un “geek”-spéléo, ou si vous avez besoin d'utiliser les capacités avancées du logiciel, vous pourrez lire le Therion Book (therion.pdf), dans votre répertoire therion/thbook.

Il y a un autre guide pour les non-informaticiens, réalisé par Wookey, baptisé “Therion - State of the Art Cave-Drawing Software” (non traduit pour l'instant !), disponible à http://therion.speleo.sk/download.php.

2- COMMENT CA MARCHE...

Pour la plupart de vos relevés, vous devrez créer 3 fichiers texte :

1) le fichier .th avec vos données topographiques (ligne d'axe en particulier) ;

2) le fichier .th2 avec vos dessins ;

3) le fichier thconfig qui peut contenir les éléments suivants :

  1. liste des éléments que vous souhaitez voir figurer sur votre document final ;
  2. réglages de mise en page, comme le lot de symboles, utilisation de légendes, etc… ;
  3. spécification de votre sortie : carte et/ou atlas et/ou modèle 3D et/ou données d'axe au format SQL.

Le plus pratique est d'enregistrer ces 3 fichiers dans le même dossier et de le baptiser du nom de la cavité.

Ainsi, dans xtherion, vous pouvez :

  1. saisir vos données topographiques dans la fenêtre d'éditeur de texte ;
  2. dessiner vos parois et autres détails dans la fenêtre de l'éditeur de carte. Ils seront convertis en commandes et sauvegardés dans un fichier .th2 ;
  3. dans la fenêtre du compileur, régler vos sources, mises en page et export dans un fichier thconfig, puis appuyer sur “Compile” pour voir vos instructions transformées en une carte finie, un modèle 3D, ou un fichier .sql.
  4. voir votre nouveau modèle 3D dans la fenêtre du visualiseur 3D si vous avez ordonné à Therion de le faire.

Les fichiers .pdf finaux peuvent être visualisés avec Adobe's Acrobat Reader si vous êtes du côté obscur de la force, Aperçu si vous êtes du côté moins obscur, ou xpdf si vous travaillez sur un système de type *nix. Vous pouvez également utiliser gv, mais pour les grandes cavités, gv est tout simplement beaucoup trop lennnnt !!

Il y a des exemples disponibles sur le site de Therion. Le mieux est de les utiliser pour faire vos premiers pas avec Therion !

L'idée d'origine de Therion était qu'il n'était pas nécessaire de noter les données LRUD, comme on réalise généralement sous terre des croquis à l'échelle dans les carnets topo. Ces croquis ont des données LRUD implicites, ainsi pouvez-vous les scanner puis les charger dans l'éditeur de cartes comme des “images d'arrière-plan”. Ensuite, vous redessinez sur vos croquis.

Depuis la version 0.3.7, Therion peut montrer la ligne d'axe avec les données LRUD dans l'éditeur de cartes, ainsi n'avez vous pas besoin d'avoir un scanner ou un croquis à l'échelle. A la place, vous avez le squelette de votre cavité sur lequel vous dessinez vos parois, etc… comme avant.

Vous pouvez choisir la méthode qui vous convient le mieux, voire combiner les deux. Ce guide se concentre sur l'utilisation des données LRUD. Pour savoir comment travailler avec des croquis scannés, lisez le guide de Wookey et/ou le Therion Book.

Therion est un programme en lignes de commande. Il demeure masqué dans la mesure où nous utilisons Xtherion comme interface graphique. Basiquement, la tâche de Xtherion est de convertir les points et lignes que nous dessinons en commandes qui peuvent être traitées par Therion quand on appuye sur F9 (n'importe où) ou sur le bouton “Compile” (dans la fenêtre du compileur).

Premièrement, télécharger le sur http://therion.speleo.sk.

Sur Windows, un double-click sur l'icône de l'installeur lancera l'installation. Répondez “Oui” (Yes) et “Suivant” (Next) à chaque question. C'est fait ? Vous pouvez maintenant démarrer Xtherion en double-cliquant sur l'icône. Comme mentionné précédemment, vous travaillerez principalement avec Xtherion qui est l'interface graphique de Therion.

Sur *nix, vous pouvez installer à partir d'un paquet binaire si vous êtes sur Debian (Sarge). Apt-get l'installera avec tous les éléments tierces nécessaires…

Si vous n'êtes pas sur Debian, vous devrez le compiler. Lisez thbook.pdf pour voir comment faire ! Regardez sur la page de Download http://therion.speleo.sk/download.php c'est bien expliqué.

3- LA BALLADE DES DAMES DU TEMPS JADIS

Pour commencer, nous vous suggérons de faire une topographie d'entraînement, avec une cavité très simple. Aucune des fonctions avancées de Therion ne sera expliquée dans le présent chapitre, mais cela suffira pour voir comment saisir des données topographiques, comment dessiner et comment compiler vos cartes.

3.1.1- Premiers contacts

Donc vous avez démarré Xtherion et obtenu une fenêtre (noire) de compileur… Et maintenant ?

Placez votre curseur sur les différents panneaux de contrôle et les boutons et vous voyez ainsi à quoi ils servent (en anglais pour l'instant…). Depuis la version 0.3.7, quand vous placez votre curseur sur un bouton ou un élément de ce type, une bulle d'aide vous explique brièvement sa fonction. La même chose se produit sur la barre des menus, en haut de la fenêtre de Xtherion. Par la suite, cette barre des menus vous indiquera également des informations sur les objets dans l'éditeur de cartes. Il vous faudra donc y faire attention !

Si vous trouvez ces bulles d'aide désagréables, vous pouvez éditer le fichier xtherion.ini. Il est placé dans les sources de therion, dans le dossier “xtherion”. Ouvrez le et cherchez la ligne :

# set xth(gui,balloons) 1

et changez la en :

set xth(gui,balloons) 0

La prochaine fois que vous démarrerez Xtherion, les bulles n'apparaîtront pas (mais les messages continueront de s'afficher dans la barre des menus !).

Evidemment, tous les panneaux de contrôle et les boutons sont désactivés tant que vous n'avez pas ouvert un fichier existant ou que vous n'en avez pas enregistré. De la même façon, certains panneaux de contrôle seront inactifs tant que vous n'aurez pas inséré un élément adéquat. Ainsi, le panneau de contrôle “Points” sera inactif tant que vous n'aurez pas inséré au moins un point. Ne vous inquiétez pas, les messages de la barre des menus apparaissent même si les contrôles sont inactifs.

Nous vous suggérons d'aller à “Fichier→Ouvrir” (2e bouton en partant de la gauche) et de sélectionner un fichier thconfig dans les exemples que vous avez chargés. Ensuite, appuyez simplement sur le bouton “Compile” ou F9. Immédiatement à côté du bouton “Compile”, vous voyez une case jaune avec la mention “RUNNING”. Therion est donc en train de créer des choses à partir des commandes se trouvant dans thconfig, et les fichiers .th et .th2. Lorsque la compilation est terminée, la boîte de message indique “OK” sur fond vert et vous trouverez dans le dossier de l'exemple choisi, les fichiers .pdf, .thm (modèle 3D) et .sql créés. Ouvrez les fichiers .pdf dans un logiciel de visualisation adapté, les .thm dans la fenêtre de visualisation 3D de Xtherion et le fichier .sql dans un éditeur de texte…

3.1.2- Données d'axe topographique et fichiers .th

Maintenant que vous avez vu de quoi Therion est capable, il est temps de faire vos premiers pas. Donc fermer le fichier thconfig d'exemple utilisé précédemment et choisissez la fenêtre d'éditeur de texte. Dans cette fenêtre, cliquez sur le deuxième bouton en partant de la gauche et choisissez template.th.

Vous voyez que ce fichier contient un grand nombre de lignes débutant par “#”. Tout ce qui est compris entre # et la fin de la ligne est du commentaire et est ignoré lors de la compilation par Therion… Nous les utilisons pour expliquer ce que chaque ligne utile signifie, quelles options sont disponibles… Donc en dehors des commentaires, template.th ne contient qu'une douzaine de lignes de commande réelles.Vous avez sans doute juste besoin de lire attentivement ce fichier et de faire quelques modifications comme suggéré dans les commentaires. Mais nous indiquons ici un guide pas à pas plus détaillé.

3.1.2.1- Style et ordre des données.

Le squelette d'un fichier .th peut être résumé de la façon suivante :

####################################################################### survey FOO -title “FOO Cave”

centerline
data normal from to length compass clino

(données mesurées ici)

endcenterline

endsurvey #######################################################################

Tout ce qui se trouve entre les 2 éléments d'une paire centerline / endcenterline appartient au même levé topographique (survey). Un “survey” peut contenir un grand nombre de choses, et en particulier d'autres surveys. Donc chaque survey doit avoir un nom particulier pour permettre une structure hiérarchique (voir plus loin pour le détail…). Pour l'instant, la chose intéressante est la centerline (ou ligne d'axe topographique)… Elle peut également être baptisée centreline. Comme vous le savez, tout le monde n'est pas naturellement anglophone !

A l'intérieur d'une paire centerline / endcenterline, il y a :

  • des lignes de données générales : unités, déclinaison, ordre des données mesurées… ;
  • des lignes de relevés topographiques proprement dites.

Dans cet exemple; il n'y a qu'une ligne de données générales : celle d'ordre et de style des données. Elle précise le style et l'ordre de vos données topographiques. Vous pouvez le changer selon vos besoins.

“normal” signifie que vous utilisez le style normal en faisant votre relevé, soit : boussole, clinomètre et décamètre. Si vous utilisez du topofil, remplacer “normal” par “topofil”. Si vous êtes plongeur, modifier “normal” en “diving”. Il y a encore d'autres styles… Pour les connaître, consulter le thbook.pdf.

Les données relevées doivent suivre le même ordre que les mots-clés de la ligne “data”. Si vous notez vos données selon un autre ordre (par exemple, vous notez la longueur en dernier), changer simplement l'ordre des mots-clés. Dans ce cas, la ligne deviendrait :

data normal from to compass clino lenght

Ou, si vous notez sous forme LRUD, vous utiliserez :

data normal from to lenght compass clino left right up down

Il y a des mots-clés pour tous les besoins… Par exemple, si vous mesurez en direct et inverse, vous pouvez utiliser les mots-clés “backcompass” et “backclino”. Ou si vous êtes plongeur, vous pouvez utiliser “depth” (profondeur). La ligne d'ordre des mot-clés peut contenir autant de mots-clés que nécessaire !. Pour la liste complète des mots-clés, reportez-vous au… thbook.pdf.

3.1.2.2- Unités

Par défaut, les unités de longueur sont le mètre et celles d'angle les degrés (360° dans un tour !). Si vous utilisez un appareil en grades (400) et disons que vous mesurez vos longueurs en yards (si vous utilisez cette dernière unité, avez-vous réellement besoin de cette version française ??), votre fichier .th devrait se présenter ainsi :

####################################################################### survey FOO -title “FOO Cave”

centerline
units lenght yard
units compass clino grad
data normal from to length compass clino

(données mesurées ici)

endcenterline

endsurvey #######################################################################

3.1.2.3- Date, déclinaison et le reste...

Vous pouvez ajouter d'autres lignes de données générales à vos données d'axe topographique. En fait, vous pouvez spécifier (au minimum) la date, la déclinaison, les participants au relevé, et l'ordre et le style des données. Ajouter les lignes d'unité si vous n'utilisez pas des degrés et des mètres. Les topographes de précision peuvent indiquer sd (standard deviation) et une ligne de calibration pour les réglages fins de leurs instruments. Encore une fois, pour la liste complète et la description de toutes les lignes disponibles, reportez-vous au thbook.pdf (je m'attaquerai à sa traduction dans un certain temps…).

Si vous avez plus d'une séance de levé, il serait mieux de préciser la déclinaison pour le survey, et pas pour le centerline. Cela permet un calcul automatique de la déclinaison. Plus de détail plus loin.

Voici un fichier .th typique d'un spéléo pur et dur. C'est le fichier template.th que vous trouverez dans le dossier “Exemples”, sans commentaires. Vous pouvez éditer les parties FOO, etc… pour l'adapter à vos besoins. Noter qu'il est préparer pour une boussole en grades (400) et un clino en degrés (360). Les données LRUD sont utilisées.

####################################################################### survey FOO -title “FOO Cave”

centerline
date YYYY.MM.DD
declination -3 degrees
team "Firstname Lastname"
team "Firstname Lastname" # add as many team lines as you need
units compass grad
data normal from to length compass clino left right up down

(données mesurées ici)

endcenterline

endsurvey #######################################################################

3.1.2.4- Données relevées (enfin !)

Ecrivez-les simplement en texte tabulé (c'est-à-dire chaque donnée du même point séparée par une tabulation). Une fois que vous avez la ligne de style et ordre des données, vous pouvez clickez sur le bouton “Scan data format” dans le panneau de contrôle “Table data”. L'ordre des boîtes de texte sera modifier selon votre ligne d'ordre des données. Si votre ligne d'ordre des données a plus de mots-clés que de boîtes de dialogue dans le panneau “Table data”, les boîtes manquantes seront ajoutées. Ainsi, vous pouvez saisir vos données d'une manière plus visuelle. Mais tant que vous n'aurez pas appuyé sur “Tab” pour passer d'une fenêtre à l'autre, vous n'aurez sauvegardé aucune saisie…

Ainsi, vos données auront probablement le format classique, disons :

0	1	16.25	345	-10 	1.00	0.85	6	1.60
1	2	4.10	275	1	0.30	0.90	2	1.60

Je suis presque certain que vous avez déjà vu ce format de données auparavant ;-)

3.1.2.5- Points fixes

Pour donner des coordonnées géographiques générales à votre ligne d'axe, vous devez disposer d'au moins un point fixe (mesuré au GPS par exemple). Il s'agit d'une station avec des coordonnées réelles, que vous ajouterez à vos données relevées sous la forme de la ligne suivante :

fix	0 	575628	4476124	1250

Comme vous le voyez, ce point fixe est la station 0 avec des coordonnées UTM. Vous pouvez avoir autant de points fixes que nécessaire. Plus il y en a, mieux c'est ! Par habitude, je les note au début de mes données relevées. Ainsi, mon fichier .th ressemble à ça :

####################################################################### survey irurixo -title “Irurixo Koba”

centerline
date 2005.02.26
declination -3 degrees
team "Mac Theknife"
team "Juxe Euskalduna" # add as many team lines as you need
units compass grad
data normal from to length compass clino left right up down

fix	0 	575628	4476124	1250
fix	42	575100	4476655 1310
0	1	16.25	345	-10 	1.00	0.85	6	1.60
1	2	4.10	275	1	0.30	0.90	2	1.60
(puis la suite des données relevées)

endcenterline

endsurvey #######################################################################

Bien. Maintenant, nous pouvons créer notre premier fichier thconfig, nous permettant ainsi d'exporter un xvi (image vectoriel xtherion) avec notre ligne d'axe topographique. Cette image sera chargée dans l'éditeur de cartes comme “image de fond”.

3.1.3- Thconfig

Dans le menu “fenêtre”, sélectionner “Compilateur” (ou F3)Puis dans fichier, choisissez “Ouvrir” (ou dans la barre des menus, clicker sur l'icône correspondante) et choisissez thconfig. Encore une fois, il s'agit d'un fichier avec commentaire. Le squelette en est le suivant :

####################################################################### source template.th

layout xvi-export

scale 1 1000
grid-size 1 1 1 m

endlayout

export map -fmt xvi -layout xvi-export -o irurixo.xvi #######################################################################

Il y a 3 parties dans un fichier thconfig :

a) source template.th est la partie listant les éléments à utiliser. Donc nous précisons ici les fichiers qui seront compilés par Therion.

b) les spécifications de mise en page. Tout ce qui se trouve à l'intérieur de la ligne layout / endlayout fait partie de la mise en page. Ces mises en page doivent être dotées de nom pour préciser quelle mise en page appliquer à quel export… On peut avoir autant de mise en page que l'on en a besoin (ou que l'on veut !).

"scale 1 1000" règle l'échelle de sortie au 1/1000e.
"grid-size 1 1 1 m" crée une grille avec un pas 1m dans toutes les directions (X, Y et Z). 

Si vous travaillez sur de grandes cavités, ce réglage peut provoquer des problèmes de mémoire lors de la compilation et il est donc préférable de régler le pas de la grille à 10 10 10 m. Encore une fois, vous pouvez spécifier d'autres unités que le mètre.

c) les spécifications de la sortie. Pour l'instant, nous n'avons qu'une sortie. Nous allons exporter une carte (une seule page, pas un atlas). Cette carte sera au format xvi (option “-fmt xvi”). Cette carte utilisera la mise en page xvi-export, préalablement définie (option “-layout xvi-export”). Enfin, l'option “-o irurixo.xvi” indique le nom du fichier xvi qui doit être créé.

C'est bon ? Alors appuyez sur F9 ou le bouton “Compile”et attendez que le dialogue à côté du bouton “Compile” indique “OK” sur fond vert.Votre nouveau fichier xvi doit se trouver dans le dossier d'exemple. Si vous avez le message “ERROR” sur fond rouge, vous pouvez voir dans la partie inférieure du compilateur ce qui est arrivé. Cette partie inférieure affiche le fichier log (c'est-à-dire les différents événements se produisant lors de la compilation) et habituellement la cause de l'erreur se remarque alors… Vous pouvez corriger les lignes fausses puis réappuyer sur le bouton “Compile” (ou F9).

Vous êtes maintenant prêt à dessiner sur votre ligne d'axe…

3.1.4- Données dessinées et fichier .th2

3.1.4.1- Images d'arrière-plan

Choisissez l'éditeur de cartes dans le menu “fenêtre” (F2). Puis choisissez Nouveau dans le menu Fichier. Le fond noir doit apparaître jaune maintenant. Il est temps de donner un nom et de sauver le nouveau fichier .th2 pour que le chemin d'accès aux autres éléments (comme les images d'arrière-plan) puisse être enregistré.

Le panneau de contrôle “images d'arrière-plan” se trouve en bas à droite de la fenêtre de l'éditeur de cartes. Cliquer sur le bouton “Insert”. Si vous n'avez pas encore enregistré votre fichier .th2, un message d'alerte vous demandera de le faire. Cliquer sur “OK” et une fenêtre d'enregistrement apparaîtra.

Après que le nouveau fichier .th2 ait été sauvé, une autre fenêtre apparaîtra, vous permettant de choisir l'image d'arrière-plan à charger. Choisissez celle que vous venez de charger (se terminant par .xvi) Ne vous souciez pas des autres boutons : ils sont utiles pour les croquis scannés.

Vous pouvez régler le zoom dans le panneau “Drawing area”, juste au dessus du panneau “Bakcground images”. Cliquer sur le rectangle juste à côté de “zoom 100%” pour voir le menu de zoom. Vous pouvez également faire défiler la zone de travail.

Vous êtes maintenant prêt à réaliser votre premier scrap !

3.1.4.2- Scraps...

Les dessins sont divisés en “scraps”. Tout ce qui se trouve entre les deux termes d'une paire “scrap/endscrap” appartient au même scrap. Nous y trouvons des points, des lignes, des surfaces. Vous pouvez voir les scraps et ce qu'ils contiennent dans le panneau “File commands” (le plus haut).

Pour les petites cavités simples, tout le dessin peut être contenu dans un scrap. Mais, si vous avez à faire à des cavités plus grandes, la réalisation d'un seul scrap peut vous conduire à des problèmes de manque de mémoire lors de la compilation. Ce n'est pas le cas de notre exemple. De la même façon, si vous avez des passages qui enjambent des zones inférieures, la seule façon de faire est de diviser en plusieurs scraps, car ces derniers ne peuvent pas avoir d'intersection entre eux (plus de détails plus loin…). Pour l'instant, on veut juste apprendre à dessiner, donc nous ne ferons qu'un seul scrap.

Dans le panneau “File commands”, cliquer sur “Insert scrap”. Le panneau “Scrap control” s'ouvrira automatiquement et Xtherion vous suggérera de le baptiser “scrap1”. Pour l'instant, c'est très bien. Ensuite choisissez une projection pour ce scrap. Comme nous dessinons le plan, choisissez “plan” dans le menu. Vous pouvez cliquer sur “Update” pour être sûr que Xtherion a bien pris en compte les modifications, mais normalement, il le fait tout seul. Le scrap est maintenant créé et vous voyez une paire de lignes dans la liste “File commands”.

3.1.4.3- Les points

Retournez dans le panneau “File commands”. Cliquer sur le menu déroulant à côté d'action pour voir les options d'action. Choisissez “Insert point”. Le bouton “Insert scrap” se transformera en “Insert point” se changera en “Insert point”. Cliquez dessus pour commencer à insérer des points. Toutes ces étapes peuvent être faites par Ctrl-P. Nous sommes désormais en mode “insertion de point”. En bas de la fenêtre, vous voyez une rectangle rouge indiquant ce que nous faisons : insert point.

Par défaut, Xtherion créera des points avec le dernier type utilisé. Le plus rapide est donc de créer tous les points du même type (par exemple, les stations), puis de changer le type (stalactite par ex.) pour insérer toutes les stalactites, et ainsi de suite.

3.1.4.3.1- Les points de stations

En premier lieu, nous devons placer et référencer les stations. L'image .xvi montre la ligne d'axe avec les stations. Cliquer sur l'une d'elles. Le panneau de contrôle des points s'ouvre et Therion règlera le type sur “station”. Dans la boîte option, vous verrez “-name X”, où X est le nom de la station ainsi qu'elle est nommée dans les données de la ligne d'axe (fichier .th). Elle a été référencée automatiquement car l'image xvi contient les données nécessaires.

Donc, lorsque vous travaillez sur des images xvi, vous n'avez pas besoin de vous soucier du référencement des stations dessinées. Ce ne sera pas le cas si vous travaillez sur des croquis scannées.

Vous pouvez quitter le mode “insertion des points” en appuyant sur la touche (esc), ou en cliquant 2 fois sur le même point. La boîte rouge en bas de la fenêtre apparaît de couleur verte et affiche le message “select object”.

Maintenant, vous pouvez cliquer sur les points pour les sélectionner. Lorsqu'ils sont sélectionnés, vous pouvez les déplacer par glissement.

Pour supprimer un point, sélectionnez-le, allez dans le panneau “File commands”, cliquer sur le menu “Action”, choisissez “Delete”, puis appuyez sur ce qui est désormais le bouton “Delete” (au-dessus du menu déroulant “Action”). Ou sélectionner le point et appuyer simplement sur “Ctrl-D” (ou la corbeille, dans les icônes en haut à droite).

Chaque scrap a besoin d'au moins 2 points de référence aux stations de ligne d'axe. A partir de ces deux points, la mise à l'échelle et la rotation peuvent être calculées dans la mesure où nous avons la position des points sur l'écran (en pixels) et leurs coordonnées réelles (à partir des données de ligne d'axe). Par habitude, j'indique toutes les stations, et pas seulement deux. Cela augmente la précision.

S'il n'y a pas au moins deux stations référencées dans le scrap, il doit être mis à l'échelle manuellement. C'est le cas lorsque vous sélectionnez la projection “none” (pour les sections transversales en particulier), donc ne vous en souciez pas pour l'instant !

3.1.4.3.2- Les flèches de pente

Donc vous avez référencé toutes vos stations dans le scrap. Et maintenant ?

Et bien, vous pouvez placer des flèches indiquant la pente. Entrez dans le mode d'insertion des points, cliquer pour insérer un nouveau point, puis aller dans le panneau de contrôle “point” et choisissez “gradient” dans le menu “type” (cliquer sur le triangle, alors que la valeur apparente dans cette boîte n'est pas sélectionnée).

Les flèches de pente doivent pointer dans une direction. Pour ce faire, cocher le bouton “orientation”. Maintenant, sur votre dessin, le point montrera une flèche. Cliquer sur la pointe de la flèche et glissez-là selon la direction désirée. On peut faire la même chose en tapant un angle dans le dialogue à côté du bouton “orientation” (360°). Maintenant, vous pouvez cliquer ailleurs pour insérer une autre flèche et ainsi de suite…

Nous le savons, c'est toujours un point, et pas une flèche de pente.Xtherion n'est pas un logiciel WYSIWYG. Vous ne voyez aucun symbole à l'écran, que des lignes et des points. Ne vous inquiétez pas : après la compilation, les symboles seront affichés dans les cartes .pdf terminées. Et vous pouvez placer le curseur sur les objets et voir ce qu'ils sont dans la barre d'état.

3.1.4.3.3- Les étiquettes

Maintenant, vous pouvez insérer des étiquettes, comme “P100”, ou “entrée”. Insérez un point où l'étiquette doit se trouver, puis allez dans le panneau de contrôle “Point”, sélectionnez “label” dans le menu “type”. Ensuite, dans la boîte de dialogue “options”, écrivez : -text “Ceci sera affiché”

Comme vous pouvez le deviner, après compilation, la carte pdf terminée affichera “Ceci sera affiché” centré au-dessus de la position du point correspondant.

Il y a quelques astuces à connaître… Si vous écrivez ceci : -text “<it> Ceci sera affiché” …. la carte compilée affichera “Ceci sera affiché” en italique.

Ou encore : si vous écrivez : -text “Ceci sera <br> affiché” …. la carte compilée affichera “Ceci sera affiché” sur deux lignes.

Ou encore : si vous écrivez : -text “<right>Ceci sera <br> affiché” . … la carte compilée affichera le texte sur deux lignes, aligné à droite. les attributs <right>, <left> et <center> n'ont d'effet que si il y a également un attribut <br>.

3.1.4.3.4- Les sections

Cette option est utilisée pour associer les sections transversales. Chaque section transversale doit être dans son propre scrap, avec la projection “none”. Plus de détails par la suite…. Insérez un point là où une section transversale a été relevée, choisissez le type “section dans le menu, et dans la boîte de dialogue d'options, écrivez : scrap <nomduscrap>

En faisant cela, vous référencez un autre scrap où la section transversale est dessinée.

3.1.4.3.5- Autres types de points

Comme vous pouvez le voir dans la liste du type de point, il y en a d'autres que ceux que nous avons mentionnés ici. La plupart sont des symboles pour les spéléothèmes, les remplissages de passage, les fins de passage, l'équipement… Nous ne les détaillerons pas ici car il s'agit seulement d'une introduction. La plupart de ces points s'utilisent sans option particulière (par exemple tous les spéléothèmes). Nous vous suggérons d'essayer de les utiliser et si après compilation ils n'apparaissent pas comme vous le souhaitez, reportez-vous au thbook.pdf (pages 18 à 20) pour voir les options mentionnées.

3.1.4.4- Les lignes

Normalement, les lignes des parois sont les premières lignes que l'on dessine dans l'éditeur de cartes. Cependant, nous avons décrit les points en premier car il nous apparaissait plus simple de commencer par les objets les plus simples qui sont en l'occurrence les points. Les lignes sont constituées de points. Vous pouvez dessiner les lignes avant les points, cela n'a aucune importance.

Pour dessiner une ligne, appuyer sur “Ctrl-L” ou classiquement, par le menu “file commands”, choisissez “Insert line” dans le menu Action et cliquer sur ce qui est devenu le bouton “Insert line”. Encore une fois, vous verrez la boîte rouge en bas de la fenêtre avec cette fois la mention “insert line point”.

3.1.4.4.1- Dessiner des lignes droites

Comme mentionné précédemment, les lignes sont composées de points. Maintenant que nous sommes dans le mode d'insertion de points de ligne, cliquer sur la zone de dessin, puis cliquer sur la même zone à une autre endroit. Vous devez obtenir une ligne droite entre ces deux points…Vous pouvez poursuivre votre ligne en cliquant où vous avez besoin. Ainsi, vous aurez une ligne constituée de segments droits entre les différents points.

Pour finir une ligne (c'est-à-dire sortir du mode “insertion de point de ligne”), vous pouvez soit a) appuyer sur la touche Esc, b) recliquer sur le dernier point que vous venez de faire. La boîte rouge en bas de la fenêtre est devenue verte, et vous êtes revenu sur le mode de sélection d'objet. Et vous pouvez appuyer sur “Ctrl-L” pour ajouter une autre ligne, ou cliquer sur des objets pour les sélectionner et les éditer. Pour supprimer une ligne entière et tous ces points, sélectionnez-la et appuyer sur “Ctrl-D”, ou allez dans le menu “File commands”, choisissez “Delete dans le menu Action et appuyer sur ce qui est devenu le bouton “Delete”.

Lorsque vous cliquez sur une ligne, un de ses points est automatiquement sélectionnéVous le remarquerez par le cercle rouge qui l'entoure. Normalement, vous cliquez directement sur les points que vous souhaitez modifier. Si vous cliquez sur un segment de la ligne, ce sera le point suivant en direction de la fin de ligne qui sera sélectionné.

Lorsqu'un point de ligne est sélectionné, vous pouvez le déplacer par un simple glissement.

Pour supprimer seulement un point sur la ligne (et non pas toute la ligne), sélectionnez-le, allez dans le menu “Line control”, cliquez sur le rectangle à côté du mot “Edit” pour voir le menu et choisissez “Delete point”.

Pour insérer un point dans la ligne, vous devez sélectionner le point se situant APRES la zone (en allant vers la fin de la ligne) où vous voulez insérer votre point, aller dans le menu “Line control”, cliquer sur le menu déroulant et choisir “Insert point”. Maintenant vous pouvez cliquer sur la ligne et insérer votre point à l'endroit souhaité. Lorsque vous avez terminé, appuyer sur la touche “Esc” ou recliquer sur le point que vous avez sélectionné au début pour sortir de ce mode.

Vous pouvez recouper une ligne. Sélectionner le point où la coupure doit être faite, puis aller dans le menu “Line control”, cliquer sur le menu déroulant et choisir “Split line”. Si à l'endroit où vous souhaitez couper la ligne il n'y a pas de point, vous devez en insérer un au préalable.

Il est temps de mentionner le taquet jaune affiché au début de chaque ligne sélectionnée. Si vous regardez du premier point vers le point suivant, ce taquet se trouvera toujours sur le côté gauche. C'est important car il indique le côté où seront dessinées beaucoup de choses. Par exemple, les hachures pour les ressauts seront dessinées de ce côté. Lorsque vous dessinez des parois, vous devez les dessiner dans le sens inverse des aiguilles d'une montre (c'est de plus en plus difficile de savoir à quel sens ça correspond avec les montres à affichage digital !), ainsi le taquet jaune se trouvera à l'intérieur et non à l'extérieur. Si vous n'avez pas tracé votre ligne dans le bon sens, ne vous inquiétez pas ! Allez dans le menu “Line Control” et cochez la case “Invert”. Cela inversera l'ordre des points et le premier point deviendra le dernier et le taquet jaune s'affichera sur le côté opposé.

Vous pouvez dessiner une aire fermée. Pour ce faire, terminez simplement sur le premier point de votre ligne, votre aire sera automatiquement fermée et vous reviendrez automatiquement dans le mode de sélection. Ou allez dans le menu “Line control” et cochez “Close”.

3.1.4.4.2- Dessiner des courbes

Comme nous venons de le voir, pour dessiner une ligne droite, il suffit de cliquer là où l'on souhaite implanter un point. Pour réaliser une courbe, vous devez en plus glisser. C'est-à-dire : choisissez un endroit approprié pour votre point, cliquez et maintenez votre bouton de souris enfoncé et déplacez la souris : vous obtenez une courbe. Plus vous déplacez la souris et plus la courbe est prononcée. Lorsque votre courbe vous convient, relâchez le bouton de votre souris. Et voilà… Et vous continuez de la même façon pour les autres points…

Attention, le dernier point dessiné est toujours sélectionné et porte 2 petits carrés rouges. Ce sont des poignées. Elles contrôlent la courbe. La première contrôle la courbe avant le point. Vous pouvez la glisser et voir comment cela modifie la courbe. La seconde contrôle la courbe en aval du point. Pour l'instant, il n'y a pas de courbes après notre point, donc elle paraît inutile, mais dès lors qu'un point existe en aval, elle prend tout son sens.

Il y a une troisième poignée, magenta, sur le point précédent. C'est ainsi qu'apparaîtra la seconde dès lors que vous aurez créer le point suivant. Actuellement, vous pouvez la déplacer pour prononcer plus ou moins la courbe mais sans changer sa direction : elle est fixe.

Dans la mesure où deux points de ligne consécutifs influencent le segment intermédiaire, les transitions seront toujours douces. Et si vous voulez, après un segment arrondi, un segment droit ? Et bien, vous tirez le second point rouge jusqu'à ce qu'il soit sur le point de ligne. Cela annule son influence et donc aucun arrondi ne se fera. Mais il y a une meilleure méthode : dans le panneau de contrôle “Line point control”, vous verrez trois boutons rouges à cocher (ils sont cochés) : «(previous) , smooth , »(next).

Décocher ”»”. La deuxième poignée n'est maintenant plus visible. Remarquer également que le bouton “smooth” est décoché automatiquement. Ainsi, la prochaine transition ne sera pas adoucie ! Vous pouvez également décocher “«” et ainsi les deux transitions ne seront pas adoucies. Ca ne vous convient pas ? Recochez “smooth” et vous aurez les deux transitions adoucies. Cocher “«” et “»” seulement si vous voulez préciser l'adoucissement.

Encore une fois, vous pouvez éditer les points après que la courbe ait été faite. Vous pouvez :

  1. cliquer sur n'importe quel point pour le sélectionner, et le glisser à sa nouvelle position ;
  2. déplacer les poignées pour avoir des courbes plus ou moins prononcées. Si vous ne voyez pas les poignées, c'est sans doute parce que les boutons “«”, “smooth” et “»” sont décochés. Donc si vous en avez besoin, cocher les ! Vous aurez ainsi 2 poignées rouges sur le point sélectionné que vous pouvez tirer dans n'importe quelle direction indépendamment et 2 poignées magenta sur le point suivant et le point précédent qui ne peuvent être déplacées que dans une direction.

Vous n'avez pas besoin de créer un grand nombre de points. Avec un peu de pratique, il est facile de dessiner n'importe quoi en plaçant des points uniquement au centre et au point d'inflexion des courbes. Pour la qualité de votre tracé, moins il y a de points, mieux c'est !

Maintenant que vous pouvez faire une ligne de la forme que vous souhaitez, voyons les types de ligne de Therion…

3.1.4.4.3- Les types et sous-types de ligne

Le type se choisit dans le panneau “Line control”. Cliquer sur le triangle à côté de “type” pour voir le menu. Choisissez celui qui vous convient. Dessinez vos lignes. Souvenez-vous que Xtherion créera par défaut les lignes avec le dernier type utilisé. Donc le mieux est de dessiner toutes les lignes du même type les unes après les autres (par exemple les parois), puis de passer au type suivant, etc…

D'autres options s'appliquent aux lignes. Ce sont les “subtype options” (sous-types). Par exemple pour un mur: “présumé”, “non topographié”, “glace”, etc… Les sous-type disponibles pour chaque type de ligne sont décris plus bas. Ils faut savoir qu'il y a deux moyens d'attribuer un sous-type à une ligne:

  • La ligne entière doit être affectée:

Ecrire dans la case Options de la fenêtre Lignes du panneau de contrôle “-subtype #”. Ne pas écrire les guillemets et remplacer le # par le sous type choisi, par exemple presumed

  • Une portion de la ligne doit être affectée:

Un mur n'a pas besoin d'être divisé en petites parties selon le sous-type. Vous pouvez utiliser une ligne de type mur et affecter les sous-types appropriés aux points de la ligne à partir du début de la ligne (où se trouve la petite coche jaune). Le sous-type “bedrock” ramènera la ligne au type par défaut (qui est “bedrock”). Il faut modifier le sous-type du point de la ligne dans la petite fenêtre noire de la partie Contrôle du point de ligne du panneau de contrôle. Ecrire simplement subtype xxxx (sans tiret). Cela change le sous-type du mur à partir de ce point, jusqu'à la fin de la ligne ou que le sous-type d'un autre point soit changé.

3.1.4.4.3.1- Les parois

C'est le type par défaut proposé par Xtherion car vous avez probablement déjà une paroi. Ce sont les limites des scraps. La plupart des symboles sont masqués s'ils sont hors de ces limites. C'est pratique, car ainsi vous n'avez pas besoin d'ajuster les autres lignes exactement. Ainsi, une fois que vos parois sont dessinées, vos contours peuvent s'étendre au-delà de ces parois. Les parties hors-limites ne seront pas visibles et pas imprimées. Cependant, comme les aires sont limitées par les lignes qui les recoupent, il est mieux que vos lignes se terminent exactement sur la paroi. Plus de détail plus loin…

La plupart des symboles sont donc masqués par les limites de scrap que constituent les parois. Pour désactiver cette fonction, précisez dans la boîte de dialogue “options : -clip off

Dans ce cas, ce symbole ne sera pas masqué. Vous pouvez également préciser ”-clip on“ pour qu'il soit coupé. Cependant, certains symboles ne seront jamais masqués (en particulier les étiquettes).

Maintenant, un cas particulier… Vous avez un passage qui se sépare en deux, puis après quelques mètres, les deux branches se réunissent. Les parois internes peuvent être vues comme une sorte de “pilier”. Mais c'est une source de confusion pour Therion car il y a maintenant 4 parois… Qu'est-ce qui est hors des limites, et qu'est-ce qui n'y est pas ? Dans ce cas, sélectionner la paroi intérieure (le “pilier”) et précisez dans la boîte options : -outline in

Ainsi, Therion saura quels sont les parois externes…

Sous-types de parois: presumed (supposé), sous-jacent (underlying), non topographié (unsurveyed), sable (sand), argile (clay), cailloux (pebble), débris (debris), blocs (blocks), glace (ice). Pour chaque cas, vous obtiendrez le symbole correspondant dans le lot de symboles que vous avez choisi (UIS, ASF, SKBB…).

3.1.4.4.3.2- Autres types de lignes

La plupart sont très explicites et n'appellent aucune option. Comme vous pouvez le devinez, contour permet de dessiner des… contours, pit dessine des puits, etc…

Rock-border et rock-edge sont utilisés pour dessiner respectivement les limites et les arêtes internes des blocs.

Section est utilisé pour indiquer l'emplacement d'une section transversale. Nous reviendrons en détail sur ce type dans la description des sections transversales.

Slope permet de dessiner un contour avec une coche pointant la direction de la pente. Pour ce symbole, vous devez cocher “L-size” dans le panneau “Line point control”.

Border est utile lorsque vous devez dessiner une ligne fermée qui définit une aire. Dans ce cas, vous souhaiterez sans doute qu'elle soit invisible. Pour cela, dans la boîte “options”, précisez : -subtype invisible

Et cette limite sera invisible. Ce sous-type s'applique à la plupart des lignes, pas uniquement aux limites. Pour plus de détails sur les différents types de lignes et les options qui s'y rapportent, voyez les pages 21 à 23 du thbook.pdf.

3.1.4.5- Les surfaces

En général, on utilise les surfaces (areas) pour précisez certains remplissages, tels que l'eau, les siphons, l'argile, le sable… Les surfaces sont limitées par des lignes. Ces lignes peuvent être de n'importe quel type, mais elles doivent être closes ou définir un espace clos (en recoupant d'autres lignes). Pour être sûr que ces lignes se recoupent réellement, il est préférable de faire dépasser les ligne des parois. Elles seront de toute façon masquées pour les parties dépassant. On peut obtenir le même effet en utilisant le type “border” avec l'option ”-subtype invisible“.

Souvenez-vous que Xtherion utilise le dernier type choisi comme valeur par défaut pour créer la prochaine surface. Donc le plus efficace est de définir d'abord toutes les surfaces d'un type, puis de changer de type, etc… Comme pour les autres objets, vous trouverez un menu “type” dans le panneau “Area control”.

Pour insérer une nouvelle surface, appuyer sur Ctrl-A ou par le processus classique, dans le panneau “File commands”, choisissez “Insert area” dans le menu “Action”, puis cliquer sur ce qui est désormais le bouton “Insert Area”. Le panneau “Area control” s'ouvrira automatiquement et vous serez alors dans le mode “insert area border” (ajout d'une limite de surface), ainsi qu'indiqué dans la boîte rouge, en bas à droite. Maintenant, cliquer sur les différentes lignes constituant les limites de votre surface.Vous devez tourner dans le sens des aiguilles d'une montre ou dans le sens inverse. C'est-à-dire que vous devez cliquer successivement sur les lignes qui se recoupent. Si vous cliquez sur deux lignes qui ne se recoupent pas, vous obtiendrez un résultat inattendu…

Remarquez que lorsque vous cliquez sur une ligne, cela apparaîtra ainsi dans le panneau “Area control” : 12-268-340. Ce sont les noms des lignes (ID) affectés automatiquement par Xtherion. Lorsque nous avons créé ces lignes, elles n'avaient pas reçu de nom et cela ne posait aucun problème. Mais maintenant que nous souhaitons qu'elle soient utilisées comme limites, elles ont besoin d'un nom. Si vous allez dans le panneau “File commands control”, vous verrez que ces noms figurent pour les lignes sélectionnées. Vous pouvez rebaptiser une ligne avec un nom plus explicite en allant dans le panneau “Line control” et en éditant l'ID dans la boîte “ID”.

Revenons au panneau “Area control”. Vous pouvez cliquer sur un nom dans la liste et cliquer sur le bouton “Delete” pour le retirer de la liste. Les lignes ainsi traitées ne sont pas supprimées, elles ne sont simplement plus considérées comme des limites.

Lorsque toutes les limites ont été définies, appuyer sur la touche “Esc”. Vous reviendrez dans le mode de sélection des objets et vous pourrez de nouveau appuyer sur Ctrl-A pour définir une nouvelle surface. Notez qu'il n'est pas possible de sélectionner une surface sur le dessin… Vous devez aller dans le panneau “File commands control” et cliquer sur la ligne appropriée pour sélectionner la surface correspondante. Une des limites de cette surface sera sélectionnée et vous verrez ainsi si c'est bien la surface que vous souhaitiez sélectionner.

Si vous ne vous en êtes pas encore rendu compte, c'est la même chose pour les lignes et les points. Si vous cliquez sur une ligne dans la liste “File commands”, cet objet sera sélectionné sur le dessin. Réciproquement, si vous sélectionnez un objet sur le dessin, sa ligne sera surlignée dans la liste. Les listes des autres panneaux fonctionnent de la même manière.

Pour supprimer une surface complète, sélectionner-la dans la liste “File commands”, puis appuyer sur Ctrl-D ou choisissez “Delete” dans le menu “Action” et cliquer sur le bouton “Delete”.

Pour une liste complète des types de surface et des options correspondantes, reportez-vous au thbook.pdf, pages 23 et 24.

Pour faire une Coupe développée, vous travaillez presque comme vous le faites pour le plan. C'est-à-dire que vous exportez une image xvi avec la ligne d'axe étendue, puis vous dessinez les points, les lignes et les surfaces.

Donc vous devez :

  1. étendre votre ligne d'axe ;
  2. éditer le fichier thconfig pour exporter l'image xvi avec la ligne d'axe étendue ;
  3. dessiner ainsi que vous l'avez fait pour le plan.

3.2.1- Etendre la ligne d'axe

Depuis la version 0.3.7, Therion étendra par défauts tous les points vers la droite. Pour modifier cela, vous pouvez éditer vos données de ligne d'axe pour ajouter certains “extend”.

Vous pouvez ajouter ”-extend left“ à la ligne “centerline” (dans le fichier .th) et tous les points seront développés vers la gauche.

Si vous avez besoin de développer quelques stations à droite, indiquer “extend right” juste avant le premier, puis indiquer “extend left” juste après le dernier. C'est tout !!

Oui, c'est très simple… Vous pouvez également indiquer, en lieu et place de “right” et “left”, “normal” et reverse”.

Dans l'exemple suivant, nous développons toutes les stations vers la gauche, mais les stations 34 à 40 doivent être étendues vers la droite. A la fin, nous avons deux petites visées correspondant à de petites prolongations mais que nous ne souhaitons pas voir sur l'image xvi. Voici le fichier :

####################################################################### survey irurixo -title “Irurixo Koba”

centerline -extend left # <<== MAIN CHANGE. ALL POINTS WILL EXTEND TO LEFT NOW
date 2005.02.26
declination -3 degrees
team "Mac Theknife"
team "Juxe Euskalduna" # add as many team lines as you need
units compass grad
data normal from to length compass clino left right up down

fix	0 	575628	4476124	1250
fix	42	575100	4476655 1310
0	1	16.25	345	-10 	1.00	0.85	6	1.60
1	2	4.10	275	1	0.30	0.90	2	1.60
(more survey data)
31      32      2.80    50.00   29.00   0.40    0.50    0.40    0.40
32      33      4.40    116.00  3.00    3.00    6.00    1.40    0.80
extend right
34      35      8.50    20.00   -5.00   1.00    2.00    1.25    0.25
35      36      3.70    45.00   4.00    0.80    2.00    0.25    0.25
36      37      3.60    51.00   13.00   0.25    0.25    0.25    0.15
37      38      2.00    41.00   16.00   0.00    2.50    2.00    0.20
38      39      4.60    115.00  20.00   1.50    1.00    2.00    1.00
39      40      4.00    393.00  -32.00  1.20    2.00    1.00    0.80
40      2       3.80    133.00  15.00   0.30    0.50    1.20    0.80
extend ignore
41      10      3.10    159.00  6.00    1.00    2.50    1.20    0.80
11      42      4.00    137.00  0.00    0.20    0.80    2.50    1.00
					    
endcenterline

endsurvey #######################################################################

3.2.2- Exporter la ligne d'axe développée en xvi

Vous devez ajouter la ligne suivante à votre fichier de config : export -proj extended -fmt xvi -o grotte_developpee.xvi

Dans le fichier d'exemple, décommentez simplement la ligne.

Maintenant, vous pouvez appuyer sur <F9> ou cliquer sur le bouton “Compile” pour créer l'image correspondante. Maintenant, vous travaillez exactement comme vous l'avez fait pour le plan.

3.2.3- Dessiner l'élévation étendue

Bien sûr les fichiers .th2 peuvent contenir autant de scraps que vous voulez… La projection du scrap n'importe pas. Ouvrez simplement votre fichier .th2 et insérer la nouvelle image d'arrière-plan. Vous pouvez la déplacer par glissement (double clique-droit et glisser) ou plus précisément en indiquant les coordonnées en pixels du coin supérieur droit de l'image insérée, puis en cliquant sur le bouton “Move to”.

Dessinez vos lignes, référencez vos stations, etc… Comme vous le voyez, tout ceci fonctionne exactement comme pour le plan.

Bien qu'une section transversale puisse théoriquement comprendre 2 stations voire plus, dans la pratique, cela ne se produit pas. Au mieux, il y aura une station si la section a été placée sur une station. La plupart du temps, il n'y aura même pas de station sur la section. Or Therion a besoin de 2 stations au moins pour mettre le scrap à l'échelle automatiquement.

Dans ce cas, nous devons donc mettre à l'échelle manuellement. Après avoir dessiné et mis à l'échelle, nous devons placer notre section sur les positions appropriées des scraps de plan et d'élévation, et dessiner une ligne indiquant la position et la direction (vers le fond ou vers l'entrée), toujours sur le plan et l'élévation. Nous allons voir tout cela en détail…

3.3.1- Dessiner les sections transversales

Ouvrez votre fichier .th2 et insérer un nouveau scrap avec la projection “none”. Ensuite, appuyer sur Ctrl-L et dessiner la… Vous pouvez la dessiner où vous voulez sur le dessin, mais il est plus pratique de la dessiner sur une grille. Il sera ainsi plus facile de dessiner à l'échelle puis de régler l'échelle.

3.3.2- Mise à l'échelle manuelle

Lorsque vous ouvrez un nouveau fichier .th2, il y a 2 carrés rouges aux angles inférieurs du dessin. Ces points sont utilisés pour la mise à l'échelle manuelle. Après avoir dessiné le plan et l'élévation développée, ils ne sont plus visibles. Si l'objet sélectionné sur le dessin n'est pas un scrap mis à l'échelle manuellement, ils ne seront pas visibles du tout. Dans le panneau “File commands control”, vous devez aller sur la ligne du scrap de votre section que vous venez de créer. Ils doivent maintenant être visibles. Cependant, si vous avez un peu trop zoomé, vous ne pouvez pas voir l'ensemble de votre dessin et donc vous devez vous déplacer sur ce dessin, ou zoomer à 25%. Une fois que vous les avez repérés, vous pouvez les déplacer.

Disons que votre section mesure à peu près 5 mètres de haut pour 2 mètres de largeur. Placer le premier point sur un point d'intersection de la grille proche du coin inférieur gauche de votre section. Placer le second sur une intersection proche de l'angle supérieur droit. Aller maintenant dans le panneau “Scrap control”, boîte de dialogue “real scale points”. Régler les coordonnées du premier point à 0,0 et celles du second à 2,5. Régler l'unité si besoin est (par défaut, ce sont des mètres). Et voilà…

La taille à laquelle vous avez dessiné votre section transversale importe peu : la taille finale sera le résultat des valeurs que vous aurez précisées pour les points “real scale”. Donc si vous souhaitez dessinez des sections transversales plus grandes que l'échelle du plan ou de l'élévation développée, vous devez donner des coordonnées fausses : ainsi, dans le cas précédent, si vous dessinez le plan et l'élévation au 1/1000e et que vous voulez que les sections apparaissent au 1/500e, vous indiquerez les coordonnées 0,0-4,10 au lieu de 0,0-2,5.

3.3.3- Positionner les sections transversales

Les sections transversales s'utilisent conjointement avec les plans et les élévations donc vous devez avoir les points correspondants dans les scraps de plan et/ou d'élévation. Il est facile d'ajouter des points de section dans le scrap de la section transversale lui-même. Dans ce cas, la section ne sera pas visible dans le pdf final.

Dans le panneau “File commands control”, choisissez le scrap de plan et/ou d'élévation approprié et cliquer sur une ligne lui appartenant. Insérer un point et sélectionner le type “section”. Xtherion ajoutera les nouveaux objets SUR la ligne sélectionnée, donc ne cliquez pas sur la ligne du scrap elle-même, sans quoi votre point ne serait pas dans le scrap désiré… Malgré tout, ne vous faites pas de souci si votre point fut inséré hors du scrap : cliquer sur la ligne du point en question et déplacer le avec les boutons “Move up”, Move down“ et “Move to” jusqu'à ce qu'il soit à l'emplacement désiré. Faites également attention à ce que la section est centrée sur ce point dans le pdf final…. Donc placer le comme il faut !!

Lorsque le point est créé dans le bon scrap, vous devez indiquez dans la boîte d'options : -scrap <scrapname>

où scrapname est le nom du scrap de la section transversale. Comme vous le devinez, le point de section appelle le scrap de section transversale lors de la compilation. Vous pouvez placer autant de points de sections appelant le même scrap que vous le souhaitez (habituellement, un pour le plan, l'autre pour l'élévation).

3.3.4- Dessiner les lignes indiquant les sections

Les lignes de section sont utilisées pour :

  1. indiquer le point où la section transversale a été relevée ;
  2. indiquer la direction dans laquelle elle a été relevée (vers l'entrée ou vers le fond). Ces lignes peuvent être en L, traversant ainsi la galerie. Une longue ligne joint la section et l'endroit où elle fut relevée, mais elle est invisible sur le passage. Au-delà du passage, une petite ligne indique, à l'aide d'une flèche, la direction dans laquelle la section a été prise. Pour obtenir cela, il y a quelques astuces…

Nous pouvons penser que nous devons tracer une ligne droite, mais nous sommes dans l'erreur !! En fait, nous devons dessiner une courbe, permettant qu'il y ait des points de contrôle autorisant le réglage des dimensions de la ligne pour la sortir du passage.

Disons que nous avons un point de section sur un passage. Cliquer sous ce point et tirer jusqu'à atteindre la paroi. Ensuite, aller sur le côté opposé, cliquer et glisser jusqu'à atteindre la première paroi. En glissant jusqu'aux parois, vous placez les points de contrôle à proximité immédiate des parois et chaque morceau de la ligne sera dessiné correctement sur le pdf.Si vous avez tiré vos courbes à l'intérieur du passage, les morceaux de la ligne indiquant la section seront visible DANS la galerie.

Même si vous avez tirer une courbe, vous aurez une ligne ligne droite entre les deux points et les morceaux de ligne seront aussi longs que vous aurez glissé la souris.

Pour avoir une flèche, vous devez ajouter l'option suivante (si vous avez relevé vers le fond !!): -direction end

Cela signifie qu'une flèche sera portée sur le point final. Comme expliqué précédemment au sujet des lignes, la flèche sera dessinée sur le côté gauche de la ligne , mis en évidence par le tiret jaune du premier point. Donc pour obtenir une ligne qui pointe vers la gauche, vous devez dessiner le premier point en dessous du second et utiliser l'option ”-direction begin“, et la flèche sera portée sur le premier point. Pour obtenir une section qui pointe vers la droite, le premier point doit être au-dessus du second et vous devez utiliser l'option ”-direction end“.

Pour obtenir un fichier pdf, il faut simplement ajouter une ligne de la forme suivante dans le fichier de configuration : export map -o map.pdf -layout map_layout Le fichier créé sera un pdf selon la mise en page définie préalablement dans “map_layout”….

Plus de détails ultérieurement !

4- LES CHOSES DIFFICILES...

A faire … ;-)

  • fr/tfc.txt
  • Last modified: 5 months ago
  • by mkern