czsk:tpj:polygon

Po spustení Therionu sa najprv objaví okno pre interpretáciu dát - therion kompilátor (ikonka s malým zubatým kolieskom hore v lište). To budeme potrebovať, až keď nejaké dáta budeme mať k dispozícii.

Prepneme preto na okno pre zadávanie a úpravu textových dát - therion textový editor (ikonka s ceruzkou, klávesa [F1] alebo položka Textový editor v menu Okno)

Z menu Súbor zvolíme položku Nový alebo klikneme na ikonku nového dokumentu. Čo ktorá ikonka znamená sa zobrazuje na spodku okna v stavovom riadku. V ľavom hornom rohu čiernej polochy sa objaví textový kurzor. Súbor uložte - napríklad ako nova_jaskyna.th do zložky nova_jaskyna. Poznámka: nedoporučuje sa používať v názvoch súborov znaky s akcentami.

Koncovka .th je vyhradená pre súbory therionu, ktoré obsahujú meračské dáta.

Všetky dáta v therione sú časťou tzv. survey, v preklade snáď meranie. V najjednoduchšom prípade to je jedna meračská akcia, ale môžu to byť aj všetky meračské akcie na jednej lokalite, alebo meračské akcie za určité časové obdobie, alebo meračské akcie na určitom krasovom území. Jeden survey môže obsahovať niekoľko vložených surveyov. Celá táto štruktúra pozdejšie slúži ako akýsi archív jednotlivých meraní.

Začneme tým najjednoduchším prípadom - jedinou meračskou akciou - jediným survey.

Každý survey začína príkazom survey a končí príkazom endsurvey. Všetko, čo je medzi týmito dvomi príkazmi, je súčasťou daného survey.

Príklad prázneho survey nájdete vo wiki v sekcii FAQ:How to enter centreline?.

survey ... -title "..."
  centreline
    team "..."
    team "..."
    date ...
    units clino compass grad
    data normal from to compass clino length
      ... ... ... ... ...
  endcentreline
endsurvey

Pre náš príklad si vystačíme s prvým a posledným riadkom, riadkami centerline a endcenterline a riadkom, ktorý začína data.

survey ... 
  centreline
    data normal from to compass clino length
      ... ... ... ... ...
  endcentreline
endsurvey

Ostatné riadky doplníme pozdejšie, ich úloha je zrejmá.

Viacriadkový príkaz centreline - encentreline bude obsahovať vlastné zmerané údaje.

Príkaz data popisuje poradie, v ako budeme namerané dáta vkladať. Je úplne jedno, v akom poradí budú, therion ich správne rozpozná práve podľa tohoto riadku. Je možné každý jednotlivý polygón zadávať v inom poradí, vždy však musí predchádzať riadok s data v správnom poradí. Parameter normal označuje normálne meranie, keď meriame vzdialenosť, sklom a azimut. Therion pozná mnoho ďaľších spôsobov merania, tým sa však teraz nebudeme zaoberať. Merania budeme zapisovať v poradí: označenie bodu z ktorého meriame (nemusí to byť iba číslo, therion akceptuje akýkoľvek reťazec znakov), označenie bodu na ktorý meriame (opäť lubovoľný reťazec znakov, ktorý nemusí mať nič spoločné s predchádzajúcim bodom), azimut, sklon a dĺžku. Ako východzie sú nastavené merania v stupňoch (360 °) a dĺžka v metroch. I tieto parametre je možné meniť pre každé meranie zvlášť.

V našom prípade doplníme namiesto bodiek za príkaz survey text “nova_jaskyna”. Tento survey sa bude teda nazývať nova_jaskyna. Vymažeme bodky za riadkom data.

survey nova_jaskyna 
  centreline
    data normal from to compass clino length
     
  endcentreline
endsurvey

Kurzor umiestnime do riadku s data a v pravej časti okna klikneme na tlačítko Nájdi formát dát. Týmto vytvoríme tabuľku presne odpovedajúcu formátu merania tak ako je uvedená v príkaze data.

Kurzor presunieme do voľného riadku pod data. Teraz môžeme pohodlne vložiť zmerané dáta. Používame desatinnú bodku, therion desatinnú čiarku nepozná. Stupne a minúty oddeľujeme dvojbodkou. Každé číslo potvrdíme klávesou [Enter], to nás zároveň posunie o riadok nižšie. Keď odentrujeme posledný riadok, meranie sa zapíše do survey a čísla bodov from a to sa zväčšia automaticky o jednu.

Polygónové merania je možné zapisovať i priamo do textu v ľavej časti okna. Jednotlivé položky oddeľujú jedna alebo viac medzier.

Zo zapísaných dát potrebujeme vygenerovať súbor, z ktorého bude možné vytlačiť polygónový ťah. Prepneme preto do okna therion kompilátor (ikonka s malým zubatým kolieskom hore v lište alebo klávesa [F3]). Vytvoríme nový súbor a uložíme ho pod menom nova_jaskyna.thconfig. Do okna napíšeme meno súboru, z ktorého má kompilátor čítať informácie a inštrukciu, čo má s dátami urobiť. V našom prípade vygenerovať mapu.

Stlačíme ikonku s veľkým zubatým kolieskom, alebo klávesu [F9], prípadne vyberieme položku Kompilovať z menu Súbor. Therion začne interpretovať dáta zo súboru nova_jaskyna.th a vygeneruje mapu s názvom cave.pdf.

Výstup z interpretácie dát sa zobrazuje v spodnej ľavej časti okna. Obsahuje užitočné informácie týkajúce sa chýb pri vyrovnávaní, speleometrické dáta apod. Kompletný výpis z kompilácie nova_jaskyna.th je tu: therion_log

Po kompilácii sa aktivujú tlačítka v pravej časti okna - napríklad štruktúru surveyov. Táto informácia môže byť veľmi dôležitá pri kompletácii zložitých jaskynných systémov.

Súbor cave.pdf je možné otvoriť v programe Adobe Reader a vytlačiť ho, prípadne v programe Adobe Illustrator, Xara, CorelDraw a použiť ako podklad pre kreslenie mapy.

Pre kreslenie mapy je zbytočné, aby vygenerovaný PDF súbor obsahoval hlavičku, naopak by mohol obsahovať metrovú sieť, prípadne celé spojnice bodov. Doplnením konfiguračného súboru nova_jaskyna.thconfig o príslušné príkazy podľa stránky s príkladmi získame nasledujúci PDF súbor. Upravený konfiguračný súbor:

  source nova_jaskyna.th
  
  layout nova_jaskyna
  
        #vypnutie hlavicky
        
        map-header 0 0 off
        legend off
      
        #siet 1x1 m
        
        grid bottom
        grid-size 1 1 1 m
        
        #spojnice bodov
        
        code metapost
        def l_survey_cave (expr p) =
              draw p withpen PenD withcolor (0.0,0.0,0.0);
        enddef;
      
      endlayout
      
      export map -layout nova_jaskyna 

Doplníme ďaľšie body a úpravíme konfiguračný súbor tak, aby sa vygeneroval okrem mapy aj pozdĺžny rez a body mali odpovedajúce čísla.

Upravený konfiguračný súbor:

  source nova_jaskyna.th
  
  layout nova_jaskyna
  
      #cisla bodov
      debug station-names
      
      #vypnutie hlavicky
        
      map-header 0 0 off
      legend off
      
      #siet 1x1 m
        
      grid bottom
      grid-size 1 1 1 m
        
      #spojnice bodov
        
      code metapost
      def l_survey_cave (expr p) =
          draw p withpen PenD withcolor (0.0,0.0,0.0);
      enddef;
      
      endlayout
      
      export map -output mapa.pdf -layout nova_jaskyna
      export map -output profil.pdf -projection extended -layout nova_jaskyna

V tomto prípade sa vygeneruje súbor mapa.pdf s polygónom pre mapu, bez hlavičky, s metrovou sieťou a očíslovanými bodmi a tiež súbor profil.pdf s polygónom pre rozvinutý rez.

mapa.pdf profil.pdf

  • czsk/tpj/polygon.txt
  • Last modified: 15 years ago
  • (external edit)