Ce chapitre décrit l’installation de Thérion et le lancement d’un exemple fournit avec le programme.

Une fois terminée, vous aurez un logiciel Thérion installé, et vous testé un exemple de ce que Thérion peut faire.


1.1 Téléchargement


Thérion a besoin de plusieurs programmes externe (càd, des programmes qui existent indépendemment de Thérion) : cavern, Tex, MetaPost et pdfTeX. xtherion qui ont également besoin de Tcl/Tk. Tous ces programmes sont disponibles gratuitement sous Linux, Windows et Mac OS X.

Vous pouvez télécharger Thérion à partir du site web http://therion.speleo.sk/download.php .

Linux Les utilisateurs de Linux (spécialement ceux de la version Debian) n’auront aucun problème, car ces programmes (excepté pour cavern qui est une partie de la suite “survex”) sont généralement inclus avec leur distrib linux, et ainsi, déjà installés. Si un program est manquant, il suffit de l’installer avec le gestionnaire de packages de la distrib, ou en dernier ressort, de récupérer le source du programme à partir du site web, dézipper le fichier, configurer le makefile, le compiler et l’installer. De plus sous Debian (ou Ubuntu), il vous suffira de tapper dans la console la ligne de commande

  apt-get install therion therion therion-viewer therion-doc
  

pour que tous les packages dont vous avez besoin soient installes en cascade sans que vous ayez a vous en inquiéter. Merci Linux.

Mais à ce jour (janvier 2008) seul le package 'therion' peut être charge de cette façon. Cela permet tout de même de mettre a jour la quasi totalité des dépendances avant de faire l'installation a la main (voir le site web http://packages.debian.org/testing/science/therion) des packages therion-viewer therion-doc et therion.

Windows La version de Therion pour Windows peut être téléchargé en version exécutable. Vous n’avez besoin que de lancer le programme d’installation “therion-full-0.5.1.exe” (le numéro de la version peut changer).

Quand vous exécutez le fichier d’installation, vous avez une fenêtre d’installation à l’écran comme celle ci-dessous. Vous devez indiquer le répertoire d’installation, et le nom du groupe de démarrage (“Démarrer | Programme” qui sera utilisé par Therion (vous pouvez accepter la proposition par défaut).

 Programme d'installation

L’installation de Thérion, installe therion, xtherion et les logiciels nécessaires, cavern, MetaPost, Tex, pdfTeX, et tout ce qui est nécessaire.

Quand l’installation est terminée, vous avez le sous-menu “Therion” dans “Démarrer | Programme”. Sélectionnez le sous-menu “xtherion” pour démarrer xtherion.

 Menu Windows

Mac (par M. Sluka) Il n’y a pas de programme précompilé pour Mac. Vous devez :

  1. Installez l’outil de développement, XCode à partir du kit d’installation Mac OS X
  2. Installez Survex: téléchargez le source tgz à partir du site web, détarrez le, ensuitez configure, make, and installez le. (Utilisez toujours sudo au lieu de su).
  3. Installez le package TeX utilisez l’installeur ii à partir de http://ii2.sourceforge.net/tex-index.html
  4. Installez AquaTcl/Tk à partir de http://tcltkaqua.sourceforge.net/ Il y a un Tcl/Tk intégré à l’installation de Mac OS X, mais l’installeur BI installera la dernière version.
  5. Pour les derniers éléments, vous aurez besoin également de ImageMagic. Vous pouvez télécharger les binaire sur http://www.imagemagick.org/download/binaries/ImageMagick-universal-apple-darwin8.7.0.tar.gz
  6. Téléchargez le package Therion. Suivez les instructions dans l’annexe du The Therion Book. Pour l’installation, utilisez sudo make install.
  7. Vous pouvez installer le visualisateur PDF xpdf. Il est meilleur qu’Acrobat reader car il ne verrouille pas les fichiers ouverts, Therion pourra alors écraser les fichiers lors des recompilations. Avec acroread vous devez systématiquement fermer les cartes PDF avant de relancer une compilation. Vous pouvez trouver xpdf pour Mac OS X at … Vous aurez besoin d’installer également le DarwinPorts: http://darwinports.com. Si port ne marche pas, exécutez la commande export PATH=$PATH:/opt/local/bin à partir du terminal. Installez alors xpdf: sudo port install xpdf.

Sous Mac OS X il y a plusieurs problèmes. Vous devez utiliser les “control key” au lieu des “command key” normales, le bouton droit de la souris ne marche pas, etc.



Le reste de cette section décrit l’installation des programmes utilisés par Thérion à partir des sources. Il n’est pas nécessaire de connaitre cela pour utiliser Thérion, et vous pouvez passer à la section suivante (si vous n’en avez pas besoin).

programme cavern

1.1.1 cavern

cavern est une partie de survex, une suite de programmes pour calculer les données topographiques. Survex est distribué sous licence GPL et peut être téléchargé librement sur http://www.survex.org. Les sources du programme sont disponibles, pour ceux qui veulent le compiler. Il est également disponible sous forme de binaires pour Linux (fichiers deb et rpm), et Windows ou Mac OS X.

interpréteur Tcl/Tk

1.1.2 Tcl/Tk

xtherion est écrit en Tcl/Tk. C’est pourquoi vous avez besoin de l’interpréteur Tcl/Tk pour l’exécuter. Si vous n’avez pas le module BWidget, vous pouvez l’ajouter : téléchargez le fichier BWidget-1.7.0.tar.gz.

NOTE: Je ne me rappelles plus si l’on a besoin également de tclunit.tcl.

Si vous prévoyez d’utiliser des images scannées au format PNG or JPEG, vous aurez également besoin des modules d’extensions tkImg: tkimg1.3.tar.bz2.

TeX (program)
MetaPost (program)

1.1.3 TeX, MetaPost et pdfTeX

TeX est généralement incluse dans la distribution Linux et contient également MetaPost. Si ce n’est pas le cas, vous pouvez télécharger Tex et MetaPost a partir de CTAN (Comprehensive TeX Archive Network) ou a partir de TUG (TeX users group).

Je voudrais dire un mot sur les problèmes possible qui peuvent arriver, et comment les résoudre. Malheureusement (ou par chance), je n’ai jamais eu de problèmes. Si quelqu’un a une expérience sur ce point …

pdfTeX est une version de TeX qui produit une sortie en PDF, a partir du DVI.

1.1.4 Thérion

Thérion peut être télécharger a partir de http://therion.speleo.sk/download.php.

Le fichier compressé (therion-0.5.1.tar.gz) contiens

  • les fichiers sources du programme thérion;
  • l’éditeur xtherion des fichiers de données thérion. Il est construit en Tcl/Tk;
  • la documentation: le répertoire thbook et les pages de manuel thérion et xtherion;
  • des exemples, dans le répertoire tests;
  • fichiers de données (définitions), dans le répertoire lib;
  • les fichiers MetaPost, dans le répertoire mpost;
  • un visualisateur 3D en OpenGL ( thtom);
  • le répertoire tex avec les fichiers therion.tex, contenant les commandes TeX de thérion;
  • glyfs et l’encodage dans le répertoire texenc;
  • le répertoire thchencdata avec l’encodage des données;
  • le répertoire thlang pour la localisation (langues locales);
  • le répertoire extern contenant des outils pour thérion;
  • le répertoire thcdt avec des fonctions pour la triangulation de Delaunay, utilisées par la reconstruction 3D des models.

Après avoir decompress2 les archives, vous devez les compiler avec la commande “make”. Par défaut, “make” génère le programme “therion” et “xtherion” et la documentation (le Therion book). Si tout va bien, vous pouvez installer therion avec la commande “make install”. Si vous n’installez par Therion, vous ne pourrez jamais utiliser therion et xtherion a partir du répertoire ou vous avez décompressé le fichier d’archive.

Le Makefile est configure pour Linux. Ceux pour Windows et Max OS X sont commentes. Si vous devez utiliser l’un d’eux, vous devez configurer le compilateur en tapant respectivement “make config-win32” ou “make config-macosx”. Cela suppose aussi que vous avez un environnement de développement “make”, MinGW oppure gcc. Bien sur, la solution la plus simple est de récupérer une version compilée du programme.

Pour installer thtom vous devez aller dans le répertoire therion/thtom/linux et exécuter “make”. Une fois finit, copier le répertoire Tom0.2 dans le répertoire lib de votre distribution Tcl/Tk (dans mon cas c’était /usr/lib/tcllib1.6). Ce répertoire doit contenir la librairie dynamique libtom.so et le fichier pkgIndex.tcl.


1.2 Passer le logiciel en Français


Une fois l'installation réalisée, pensez a éditer le fichier therion.ini présent dans le répertoire d'installation pour modifier la langue ( ajouter la ligne “langue fr” )

    ### Output character encodings ###
    # encoding-default  ASCII
    # encoding-sql  ASCII

    ### Default regional settings ###
    # language  en_UK
    language  fr
    # units metric

Pour que les légendes des topographies soient en Français.

De la même façon, éditez le fichier xtherion.ini pour modifier la langue utilisée dans l'interface du logiciel :

   ## prefered language for messages
   ::msgcat::mclocale fr

Voir l'annexe 1.A de ce chapitre pour plus d'infos.

1.3 Exécution


Therion est un logiciel pour des topographies de haute qualité. Au cœur de ce système, il y a le langage therion, c’est un langage pour définir via des fichiers texte les éléments graphiques de la topographie, cad, des points, des lignes, des symboles, et ainsi de suite.

Les fichiers texte, écrits dans le langage therion, sont utilisés par le programme “therion” pour générer la topographie en PDF. Ce programme se base sur d’autres programmes pour calculer les données topographiques, “cavern”, et pour produire des dessins de qualité, MetaPost, TeX, et pdfTeX 2 .

Alors qu’il est facile d’écrire et de modifier les fichiers de données topographiques avec un simple éditeur de texte, faire de même pour les fichiers de dessin l’est beaucoup moins, même si cela reste possible. Il est préférable d’utiliser un programme avec une interface graphique. Un tel programme, “xtherion”, est distribué avec “therion”. N’importe quel autre programme graphique compatible avec le langage /therion/ remplirait également la tache. “xtherion” est écrit en Tcl/tk, c’est pourquoi il est nécessaire d’avoir l’interpréteur Tcl/Tk installé sur son poste.

xtherion n’est pas un programme WYSIWYG (ce que vous voyez est ce que vous aurez), ce qui rend l’utilisation moins conviviale. D’un autre coté, l’approche suivie par therion qui sépare les données de leur présentation (et/ou du résultat final), donne plus de liberté pour les résultats (impressions), et rend la maintenance plus simple. Par exemple, la fermeture d’une boucle, est plus facilement prise en compte lorsque les données utilisées pour générer la carte sont toujours les données originales (et non des données obtenues par résultat d’un calcul).

 Démarrage de Thérion

Assurez-vous que les répertoires contenant le programme “therion” (et les autres programmes utilisés) sont bien inclus dans le “PATH”. Les utilisateurs sous Windows qui ont installés therion avec le programme d’installation, ne devraient pas avoir de problème.

Les utilisateurs sous Linux ne devraient pas avoir de problème non plus. Pour vérifier que tous les programmes sont accessibles dans le PATH tapez la commande “which cavern mpost tex pdftex therion xtherion”. Si le programme les trouve, le chemin complet est affiché. Sinon, le nom du programme, avec un point-virgule est affiché. A la place de “pdftex;” vous devriez avoir “/usr/lib/pdftex/bin/pdftex”. Il n’est pas nécessaire que “xtherion” soit accessible via le “PATH”. Il est possible de le lancer avec son path. Si vous voulez trouver le logiciel dans le “PATH”, vous pouvez ajouter le répertoire, qui contient le programme au “PATH” avec la commande : “export PATH=$PATH:directory” (pour le shell “bash”, pour les autres shell, la commande est légèrement différente ; “echo $SHELL” vous indiquera quel shell vous utilisez).

Maintenant allez dans le répertoire de therion et tapez la commande “xtherion” (ou “./xtherion/xtherion” si vous n’avez pas encore installé therion. Une petite fenêtre s’affiche, pour vous indiquer que xtherion est en cours de démarrage. Après un court instant, la fenêtre xtherion apparaît comme la figure ci-dessous.

 Ecran de Thérion

La fenetre xtherion a une barre de menu avec 4 menus : “File”, “Edit”, “Window” et “Help”. Une liste de fonctions est disponible pour chaque menu. Il y a deux zones de travail (toutes les deux vides et noire au démarrage) : celle du dessus pour les fichiers de configuration, celle du fond pour les logs. Le panneau de contrôle est sur la droite, et la barre de status au bas de la fenêtre.

1.2.1 Help (Aide)

Le menu “Help” a 3 sous menus:

  • “Control” ouvre une fenêtre avec le résumé (documentation) des commandes (controls);
  • “BAC calculator”: une calculatrice pour el pourcentage d’alcool dans le sang (Blood Alcohol Calculator), le taux métabolique d’élimination de l’alcool (Metabolic Removal Rate (MRR) et le temps que vous devrez attendre avant de dessiner la topographie (ETA, Estimated Time of Arrival);
  • “About” affiche la version du programme et les noms des auteurs.
1.2.2 File (Fichier)

Comme vous pouvez vous y attendre, ce menu a des sous menus pour créer (“New”) ou ouvrir (“Open”) un fichier de configuration, le sauvegarder (“Save”) et le fermer (“Close”). Il y a aussi un sous-menu pour compiler le projet, “Compile”, et “Exit”, pour quitter xtherion.

xtherion a plusieurs raccourcis claviers, cad des touches ou combinaisons de touches équivalentes a des menus ou des commandes. La plus importante est “F9” qui compile le projet. C'est-à-dire qu’appuyer sur “F9” équivaut a choisir le menu “File | Compile”.

1.2.3 Window (Fenêtres)

Le menu “Window” alterne les pages de travail de xtherion:

  • “Text Editor”: Editeur de texte des fichiers de données topographiques (centerline);
  • “Map Editor”: Editeur du dessin des topographies (scraps);
  • “Compiler”: L’éditeur du fichier de configuration et le compilateur du projet. C’est dans ce mode que demarre xtherion.
  • “Model Viewer”: pour voir en 3D la cavité.

Chaque mode interactif a sa propre barre d’outils (avec son menu spécifique), sa barre de statut (messages de statut spécifiques pour chaque mode), et ses panneaux de contrôle (avec des actions spécifiques pour chaque mode).

Il y a 3 menus pour régler la taille de la fenêtre, pour prendre tout l’ecrant “Maximize”, ou “Normalize” pour lui donner la taille plus petite modulable à la souris. Enfin pour positionner la page des contrôles sur la fenêtre à gauche ou à droite, “Switch Panel”.

Enfin, il y a le sous-menu “KBD Encoding” pour choisir le type d’encodage du clavier. Si vous voulez en rajouter un, contactez moi, je le rajouterai ici.

1.2.4 Toolbar (barre d’outils)

La barre d’outils de xtherion (juste sous le menu) a été introduite avec la version 0.3.10. Elle dispose de boutons pour les différentes opérations comme créer un nouveau fichier, ouvrir un fichier, enregistrer, fermer le fichier, changer de mode de “xtherion” et également compiler.

 Barre d'outils

Dans le mode éditeur de carte, la barre d’outils a également des boutons supplémentaires à droite pour les opérations les plus fréquentes : zoom avant et arrière, insertion de scrap, de points, de lignes et de surface, sélection et suppression des éléments.

 Barre d'outils graphique

1.2.5 Controls panel (panneau de contrôle)

Le panneau de contrôle est situé par défaut a droite et contient plusieurs boutons sur un fond bleu : ce sont les contrôles. Le nombre et le type des contrôles dépendent du mode interactif. Le panneau peut être déplacé a droite ou a gauche de la fenêtre avec le menu “Window |Switch panels”.

Chaque contrôle peut être ouvert ou fermée : quand il est ouvert, les informations du contrôle sont visible sous le bouton bleu. Pour ouvrir ou fermer le contrôle, double cliquez sur le bouton.

1.2.6 Status bar (barre d’état)

La fenêtre de xtherion a une barre d’état au bas de la fenêtre. La barre d’état affiche des informations utiles sur le status du programme. C’est pourquoi vous devez prendre l’habitude de lire son contenu.

1.2.7 Exercice

Maintenant, essayez de passer d’un mode à l’autre en cliquant sur le bon menu. Notez comment les boutons sous la barre de menu changent. Notez que le libellé du mode apparaît dans le titre de la fenêtre. Sélectionnez le sous-menu “Help” (aide). Vous pouvez également tester le “BAC calculator” …

Enfin, allez sur la fenêtre du mode “Compiler” .


1.3 Essayer xtherion


Nous allons commencer par travailler sur un exemple, vous pouvez lancer xtherion avec un des exemples fournis avec le logiciel. De toute façon, il est préférable de voir en premier lieu comment Thérion organise les données.

1.3.1 Les fichiers de Thérion

La topographie d’une grotte est un “projet”, avec un fichier de configuration qui indique ce qu’il faut faire, comment le faire, plus des fichiers de données. Il peut y avoir plusieurs fichiers de configuration, afin de calculer les mêmes données de différentes façons et fournir des résultats différents (topo plus ou moins détaillée par exemple).

Therion utilise des fichiers texte, que vous pouvez lire et éditer avec n’importe quel éditeur de texte en dehors de xtherion. Bien sur, si vous ne respectez pas la syntaxe de therion, les fichiers ne compileront pas et therion ne générera pas le document que vous souhaitez.

Pour cette raison, il est préférable d’utiliser xtherion pour éditer les fichiers de therion. Il ne fait pas de contrôle de syntaxe, mais il vous aidera beaucoup dans le développement de votre projet topographique.

thconfig (Fichier de configuration de Therion)
Par convention, le fichier de configuration de therion est nommé thconfig. Ce n’est pas obligatoire, et il peut être nomme différemment. Quand vous ouvrez un fichier de configuration dans xtherion, par défaut, il affiche uniquement les fichiers qui contiennent la chaîne “thconfig” dans leur nom (“ma-topo.thconfig”, “thconfig_grotte”, etc.), mais vous pouvez choisir de sélectionner “tous” le fichiers (“all”). Par convention, les fichiers therion de données topographiques ont l’extension “.th” et les fichiers de cartes “.th2”.

1.3.2 Exemple

Maintenant créez un répertoire pour cet exemple. Je l’appellerais gm-therion. Pour le moment, il est vide, mais il va être remplit de fichiers therion et d’images pour le dessin. Les fichiers générés seront également placés ici plus tard.

Placez-vous dans ce répertoire et exécutez la commande

    xtherion
  

Après la petite fenêtre de démarrage, qui vous indique que xtherion démarre, la fenêtre de xtherion apparaît, en mode compilation.

Dans le panneau de contrôle vous trouvez

  • “Settings” (paramètres), avec les paramètres de configuration du programme : “Working directory” (répertoire de travail), le nom du fichier “Configuration file” (fichier de configuration actuel), et d’autres options de la commande therion.
  • “Survey structure” (configuration de la topo) affiche l’organisation hiérarchique de la topographie (découpage en fichiers topo).
  • “Survey info” (informations topographiques) affiche quelques informations sur le fichier topographique sélectionné dans la “Survey structure”. Les informations sont disponibles après que le projet est été compilé.
  • “Map structure” (organisation des cartes) affiche l’organisation des cartes (calculées).

 Ecran d'exemple

Vous devez ouvrir un fichier de configuration pour activer ces contrôles. En conséquence, sélectionnez le menu “File | New” et choisissez le nom de fichier propose comme fichier de configuration (nomme “thconfig”), puis cliquez sur “Save as”. A ce moment, les contrôles sont actifs et vous pouvez voir les paramètres du projet. Mais, si vous essayez de compiler, vous aurez une erreur car vous n’avez spécifié aucune commande de configuration, ni indique de données topographiques.

Vous ne pouvez pas non plus exécuter therion avec une option (ou les 2) “-h” (help) ou “-v” (version). Ecrivez l’option dans la zone texte (panneau de contrôle) sous “Command line options” et cliquez sur le bouton “Compile”. Le résultat est très court, et le résultat de therion est affiche dans la partie basse de la fenêtre.

environnement (therion)
Une autre information utile que fournit therion même si le fichier de configuration est vide, est le contexte d’exécution. C'est-à-dire, son environnement. Ecrivez l’option de commande “–print-environment” et compilez. Les variables d’environnement sont

  • le fichier d’initialisation : /etc/therion.ini;
  • le fichier de configuration du projet;
  • INIT: le path (liste de répertoires) ou therion cherche le fichier d’initialisation therion.ini. Ce répertoire est aussi utilisé par xtherion pour son fichier d’initialisation, xtherion.ini.
  • SOURCE: le path des fichiers de données (.th e .th2) et le fichier de configuration (“thconfig”) pour therion;
  • METAPOST: la commande MetaPost;
  • PDFTEX: la commande pdfTeX.

Ces informations sont utiles pour résoudre des problèmes d’installation, tel que, par exemple, therion qui ne trouve pas MetaPost.

Maintenant fermez le projet : sélectionnez le menu “File | Close”.

1.3.3 Une topographie

Il est maintenant temps de voir comment “therion” travail. Ouvrez le fichier de configuration des exemples fournis avec le logiciel : sélectionnez le menu “File | Open”. Vous avez une fenêtre de sélection de fichier. Allez dans le répertoire d’installation de Thérion et sélectionnez le fichier thconfig. Cliquez sur le bouton “Open ”. Le fichier apparaît dans la partie supérieure de la fenêtre Thérion.

Pour le moment, ne vous en préoccupez pas, lancez juste le menu “File | Compile” (ou appuyez sur la touche F9). La zone texte près du bouton “Compile” devient jaune avec le texte “RUNNING”. Le résultat de la compilation sera affiché dans la partie basse de la fenêtre. A la fin, si tout s’est bien passé, la zone teste deviendra verte avec le texte “OK”. Si quelque chose se passe mal, il deviendra rouge avec le texte “ERROR”. Dans ce cas, vous devez identifier le problème et le résoudre. Attention, la zone texte peut afficher “OK” même si des erreurs mineurs (warning) se produisent : vous devez parcourir la fenêtre de sortie (partie basse de la fenêtre) avec l’ascenseur pour vérifier qu’il n’y a pas de warnings. Pour les exemples fournis avec la distribution du logiciel, il n’y a pas d’erreurs.

Sur Mac OS X xtherion termine toujours la compilation avec le message rouge “ERROR”, même s’il n’y a pas d’erreurs. Vous devez vérifier la fenêtre de résultat de compilation pour contrôler qu’il n’y a pas eu d’erreur.

Maintenant vous pouvez ouvrir le fichier “cave.pdf” avec un visualisateur PDF (xpdf ou acroread si vous êtes en mode ligne de commande, sinon double cliquez avec la souris sur le nom du fichier; xpdf a une commande intéressante “reload” qui permet de relire le fichier sans avoir besoin de le fermer), et regardez le résultat.

therion stock des fichiers temporaires dans le répertoire $TMP/th$PID où PID est l’identifiant du processus de la tâche therion (et pas de xtherion). Ces fichiers temporaires sont supprimes a la fin de l’exécution.


1.A Configuration de Therion


therion et xtherion se basent sur des variables d’environnement et des fichiers d’initialisation pour configurer leur mode de fonctionnement.

environnement (therion)

1.A.1 Environnement

therion utilise les variables suivantes

  • THERION, chemin de recherche pour les fichiers d’initialisation;
  • HOME, le path $HOME/.therion est utilisé dans la recherche des fichiers d’initialisation quand ces fichiers ne sont pas trouvés dans le path THERION (ou si ce dernier n’est pas définit);
  • TEMP et TMP sont utilisés pour construire le répertoire des fichiers temporaires. Celui-ci est $TMP/th$PID, où $PID est le process id. Ces variables sont aussi utilisées pour le chemin du répertoire de debug où les fichiers de données temporaires sont enregistrées, $TMP/thDEBUG.
1.A.2 Fichiers d’initialisation

Les fichiers d’initialisation, “therion.ini” et “xtherion.ini”, sont écrits, respectivement, avec une syntaxe similaire aux fichiers de données. C'est-à-dire avec des lignes de commandes et des commentaires (ces derniers commencent par le caractère '#').

Thérion cherche les fichiers d’initialisation dans les répertoires dans l’ordre suivants (sous Linux et sous Windows après les deux premiers, les choses sont légèrement différentes) :

  1. $THERION
  2. $HOME/.therion
  3. /etc
  4. /usr/etc
  5. /usr/local/etc

La recherche s’arrête quand le fichier d’initialisation est trouvé. Si le fichier d’initialisation n’est pas trouvé therion utilise des valeurs par défaut (codées dans le programme). Les commandes des fichiers d’initialisation sont :

  • “encoding-default”, fixe la sortie par défaut d’encodage;
  • “encoding-sql”, fixe le format d’encodage pour les données exportées dans des scripts SQL;
  • “language”, fixe la langue pour les textes de légende sur les topographies. Par exemple “language fr”;
  • “mpost-path”, indique le chemin pour MetaPost. Par défaut “mpost”;
  • “pdftex-path”, le chemin pour pdfTeX. Par défaut “pdfetex”;
  • “source-path”, le chemin de recherche pour les fichiers de données (.th et .th2) et le fichier de configuration (“thconfig”).
  • “tmp-path”, indique le répertoire ou les fichiers temporaires devront être crées. Par défaut “/tmp”.
  • “tmp-remove”, indique la commande pour supprimer les fichiers temporaires.
  • “tex-env” utilisée uniquement sous Windows (à faire);
  • “tex-font” indique les fontes pour l’encodage. La syntaxe est “tex-font encoding rm it bf ss ssi”, où le nom de l’encodage est suivit par la fonte pour les 5 styles : normal, italique, gras, sans-serif, et sans-serif italique.

Le fichier d’initialisation de xtherion contient une liste de variables qui modifie le comportement du programme. Les valeurs de ces variables peuvent être fixées aux valeurs par défaut. Parmi celles-ci nous avons :

  • le répertoire de travail. C’est le répertoire que xtherion affiché par défaut lorsqu’on lui demande d’ouvrir des fichiers. J’ai trouvé pratique de le fixer au sous répertoire “Caves” de mon répertoire de données (“mes documents” par exemple), car c’est ici que j’enregistre toutes mes topo : set xth (gui,initdir) $env(HOME)/Caves.
  • la langue utilisée par l’interface de xtherion. Vous pouvez la définir en retirant le commentaire sur la ligne ::msgcat::mclocale XX. Replace “XX” avec le code de votre langue (fr pour le français). Ce doit être l’une des langues prises en charge par le programme, sinon xtherion utilisera l’anglais.
1.A.3 Exécution

Thérion repose sur 3 programmes externes pour compiler les cartes d’un projet:

  • cavern, pour calculer les données topographiques;
  • metapost, pour calculer les scraps (dessins);
  • pdfTeX, pour assembler les scraps et construire une topographie.

C’est pourquoi vous pouvez voir dans les résultats de la construction du projet (dans la partie basse de la fenêtre de compilation de xtherion) les sorties écran de ces programmes.

xtherion sauvegarde les fichiers de données “.th” et “.th2” et le fichier de configuration sur le disque dur lors de la compilation. C’est pourquoi ils sont toujours synchronisés avec leur version utilisée par xtherion. Ensuite il appel therion. En fait, vous pouvez compiler sans passer par xtherion et appeler directement therion à partir du shell (la ligne de commande), c’est ce que je fais quand je veux générer une topo d’une série de fichiers sans les éditer.

 Flux d'échange

therion calcul les fichiers de données et coordonne le travail de programmes externes [thbook 8]. Il lit les fichiers de données et interprète les lignes de commande qu’ils contiennent. D’abord il calcul la position des stations topo. En particulier il recherche les bouclages topo et distribue l’erreur sur les différentes visées.

Ensuite il calcul les données des scraps (fichiers .th2) et les transformes suivant la position des stations topo. Après cela, il export les données en fichiers MetaPost (.mp), et appelle le programme mpost. Celui-ci calcul les fichiers “.mp” et produit des fichiers PostScript (.ps). Un petit fichier pour chaque scrap, c'est-à-dire, pour chaque partie de la carte.

Les fichiers PostScript sont calculés par therion et convertis en format pseudo-PDF. Enfin, il appel pdfetex pour transformer ces fichiers pseudo-PDF. Ce programme produit les topographies en format PDF, en prenant soin du format et des inclusions de texte.

  • fr/tbe/wiki1.txt
  • Last modified: 12 years ago
  • (external edit)