Da Compass a Therion

Questa pagina descrive come convertire i dati Compass in un file di Therion e i disegni per avere un progetto Therion completo della grotta. È adatto per grotte piccole e semplici, in cui non serve una organizzazione dei dati strutturata. Può essere un modo per cominciare ad usare Therion.

Si parte dal presupposto di avere i dati di poligonale come file Compass, ad esempio grotta.dat, e le restituzioni di pianta e sezione tracciate a mano ed acquisite come immagini digitali. Per poter “referenziare” pianta e sezione sulla poligonale, le restituzioni devono contenere le posizioni dei capisaldi (almeno due) oppure la barra di scala. È conveniente, anche se non essenziale, che il Nord nella pianta risulti verso l'alto nell'immagine, e parimenti per la direzione verticale della sezione.

Il file .th

Questo file non è strettamente necessario. Puoi farne tranquillamente a meno se referenzi gli scrap con la barra di scala, come descritto sotto, e possibilmente con un caposaldo di riferimento. In tal caso puoi scrivere un file semplice semplice direttamente con xtherion,

survey grotta -title "La Mia Grotta"

  centerline
    // cs UTM32     // per specificare il sistema di coordinate
    // fix 1 X Y Z  // per specificare le coordinate UTM32 del caposaldo 1

    date 2010.12.15
    team "Tuo Nome" tape notes
    team "Tuo Amico" compass clino
  endcenterline

  input grotta-p.th2
  input grotta-s.th2
endsurvey

Ci sono dei limiti in queato approccio. Per prima cosa Therion non ti può dare informazioni su quanto è lunga o profonda la grotta perché gli mancano i dati per fare questi conti. Poi non puoi georeferenziare il tuo rilievo: per questo dovresti avere almeno un caposaldo di cui dai le coordinate (i comandi sono “fix” per dare le posizioni e “cs” per definire il sistema di coordinate). Infine Therion non può fare il modello 3D sempre perché gli mancano le informazioni. Malgrado tutti questi limiti può risultare un primo approccio per imparare a fare i disegni con Therion.

Se invece, vuoi un file di dati “.th” vero e proprio devi convertire i dati della poligonale. Lo script PERL dat2th.pl (è un file tar-gz: scompattalo) fa proprio questa conversione. attenzione che non è perfetto, e fa un po' di confusione se i nomi dei capisaldi contengono lettere accentate, o altri simboli “strani”. La sintassi è dat2th.pl grotta.dat. Ne risulta il file “grotta.th” con i dati di poligonale in formato Therion. Il nome è lo stesso del file Compass, l'estensione cambia da “.dat” a “.th”. Devi aprirlo con xtherion: puoi aggiungere eventuali comandi per Therion, ma la cosa importante sono le due righe commentate (incominciano con “#”) per includere i file degli scrap di pianta e sezione. Questi sono denominanti (con grande fantasia) “grotta-p.th2” e “grotta-s.th2”. Di nuovo, il nome è quello del file Compass, con aggiunto “-p” e “-s” rispettivamente, e l'estensione è “.th2” come per i file Therion dei disegni.

Nota che, se vuoi georeferenziare i tuoi dati, in Compass le posizioni dei capisaldi di riferimento sono scritte nel file .MAK di progetto. Devi copiarle a scrivere i relativi comandi (“fix” e “cs”) nel file Therion.

Il file di configurazione "thconfig"

Sempre in xtherion scrivi un file di configurazione

   source grotta.th
   
   export map -proj plan -o grotta-p.pdf
   
   export map -proj extended -o grotta-s.pdf
Definire come sviluppare la sezione longitudinale

A questo punto puoi già “compilare”, cioè eseguire therion, ed avrai due file PDF con le poligonali. Quello della pianta non è molto utile. Quello della sezione longitudinale, invece ti serve per decidere come “espandere” i tiri di poligonale, cioè se verso destra oppure verso sinistra, o ancora verticali. Suppongo che non hai anelli chiusi, altrimenti il rilievo diventa complicato e non ti bastano questa semplici note. Per questo scopo viene comoda l'“anteprima” (preview) del PDF invocata direttamente da xtherion: scrivi il nome del file che vuoi visualizzare (nell'esempio “grotta-s.pdf”) nel campo appropriato della finestra del compilatore. Inserisci i comandi “export left” e “export right” in modo opportuno fra le linee dei dati nel file “grotta.th” (lavorando nella finestra dell'editor di testo di xtherion), e controlla il risultato compilando.

Attenzione che ogni comando “extend” si applica a tutti i dati che seguono, fino a quando non subentra un altro comando “extend” che modifica il verso in cui sviluppare la poligonale. Per inciso, ci sono altri modi di sviluppare: “extend normal” e “extend reverse” sono indicazioni relative invece che assolute, “extend vertical” per dire di non sviluppare né a destra né a sinistra, e “extend ignore” (per le chiusure degli anelli).

Quando sei a posto con gli “extend”, puoi passare ai disegni di pianta e sezione. Attenzione: questo lavoro di decidere come sviluppare la sezione longitudinale, non è necessario se la scala dei disegni viene impostata attraverso la barra di scala, e non identificando dei capisaldi.

I file ".th2"

È il momento di creare gli scrap. Cominciamo dalla pianta. Per prima cosa seleziona la finestra dell'editor grafico di xtherion, crea un nuovo file (File→New) e salvalo (File→Save As) con nome “grotta-p.th2” (lo stesso che c'è scritto nel file dei dati). Decommenta la linea relativa nel file dei dati, rimuovendo il carattere “#”.

In xtherion, inserisci un nuovo scrap (Ctrl-R oppure Edit→Insert→Scrap). Il nome, ovvero l'“id”, non è importante se ti basta uno scrap per il disegno (è però importante se il disegno è complesso, ma qui ci limitiamo a semplici piccole cavità). Invece il tipo di projezione è importantissimo: nelle opzioni del blocco di “Scrap” devi selezionare “plan” per la pianta e “extended” per la sezione longitudinale. Nella immagine allegata questo è indicato da un cerchio rosso.

Iniziare uno scrap

Ora devi specificare la scala dello scrap. Inserisci come immagine di background la scannerizzazione del tuo disegno. Se hai dei capisaldi, puoi inserire dei punti (Edit→Insert→Point) di tipo “station” clickando su di essi; ricordati di specificarne il nome scrivendo nel campo opzioni (options) '“-name 1” (o quale sia il numero del caposaldo). Alternativamente, se non hai capisaldi, devi specificare la scala dello scrap trascinando gli estremi della linea rossa sugli estremi della barra di scala ed indicando la dimensione (in metri) corrispondente alla barra nella apposita casella della sezione “scrap”. Nella immagine la dimensione di 10 m è evidenziatoa con un cerchio rosso. Attenzione ho messo 10 m in orizzontale e 0 m in verticale perché la barra è orizzontale. Se non fosse tale dovrei mettere altri valori. È buona norma mettere anche un caposaldo “virtuale”, un punto di tipo “station”; gli puoi dare il nome che preferisci e specifica che sia non visibile nella mappa “-name 1 -visibility off” (“1” è il nome). Questo ti permette di georefernziare lo scrap, calcolando (o stimando) le coordinate (nel mondo) di questo punto.

Adesso traccia il contorno. Inserisci delle linee (Edit→Insert→Line) di tipo “wall” ricalcando il contorno nel disegno. Ricordati di seguire il contorno in senso “antiorario” in modo che la grotta stia sulla sinistra di esso. Prima di procedere con i dettagli, verifica che non ci siano errori con l'anteprima di compilazione. Se tutto va bene, inserisci i dettagli: gli altri punti per la simbologia speleologica, e le altre linee, interne al contorno della grotta. Aggiungi le scritte (punti di tipo “label”) etc.

Quando la pianta è finita procedi allo stesso modo con la sezione longitudinale.

Per continuare

Ci sono tante cose che ho tralasciato in questa pagina. Questa è una lista, certamente non esaustiva; però se continui ad usare Therion, poco alla volta impari e dopo un po' sarai in grado di fare restituzioni anche di grotte complesse, direttamente in Therion.

  • I possibili tipi dei punti (point), simboli e altro. Ce ne sono davvero tanti: sul Therion-Book sono descritti tutti. Imparali un poco alla volta, cominciando da quelli più comuni (air-draught, water-flow, label, stalactite, stalagmite, blocks, debris, sand, clay, …).
  • I vari tipi di linea (line). Anche queste sono molte, e anche per queste conviene cominciare dalle più comuni (wall, pit, chimney, rock-border, border, arrow, …). In particolare “wall” ha tanti utili sottotipi (subtype).
  • Le zone (area) tipo “water”, “sump”, etc. Sono poche, ma è bene darci un'occhiata.
  • Come completare l'output, con la legenda, la griglia delle coordinate (georeferenziando i dati).
  • Produrre altri tipi di output: modelli 3D (per loch), liste, etc.
  • Grotte complesse, in cui uno scrap non basta più. Qui devi dividere il disegno in più pezzi e dire a Therion di unirli. Il comando è “join”: lo trovi spiegato, come sempre, nel Therion-Book.
  • it/compass.txt
  • Last modified: 8 years ago
  • by marco_corvi