Queste sono alcuni suggerimenti che mi son venuti mentre cercavo di usare il DistoX e PocketTopo assieme a Therion. (Guarda anche la pagina http://therion.speleo.sk/workflow.php
e i link rilevanti. Qui si suppone che tu abbia familiarità con il DistoX, PocketTopo e abbia letto i loro manuali)

Disclaimer: Non ho esperienza nè alcuna qualifica in “Paperless Cave Surveying” (rilievo ipogeo senza carta). Ho comprato un DistoX, e presun palmare in prestito, ed ora li porto con me in grotta nelle esplorazioni. Quelle che seguono sono alcune regole che mi sono fatto in modo che il sistema risulti davvero più veloce e più semplice che scrivere su un pezzo di carta, anche se si registra un numero di dettagli dieci volte superiore …

Ogni suggerinmento è benaccetto. Aggiungili in questa pagina (e possibilmente anche nella pagina in inglese).

Bruce Mutton

Sono state usate le versioni 1.22 e 1.34+ di PocketTopo e 5.3+ di Therion

Ecco alcune idee per minimizzare la confusione e la perdita di dati.

DistoX

Uso del DistoX in generale

  • Ricorda che ogni bottone ha almeno due funzioni, la prima quando viene premuto per un breve tempo, la seconda quando è tenuto premuto a lungo. Per fare le misure bisogna premere il bottone “DIST” per un tempo breve. Questo non produce alcun suono: solo dopo che il Disto ha determinato se la misura è riuscita o meno emette un suono (breve in caso di successo, lungo in caso di fallimento).
  • È praticamente impossibile fare misure con la mano guantata e col DistoX in una busta di plastica traparente (per proteggerlo dall'umidità). La soluzione consiste nel mettere una fascetta elastica intorno al Disto che copre il bottone “DIST”, prima di inserirlo nella busta di plastica. In questo modo è più semplice localizzare il bottone al tatto.

Il DistoX con il palmare (PDA)

  • Quando arrivi sul caposaldo, esegui subito le misure trasversali, PRIMA di fare il la misura del prossimo tiro di poligonale. Assicurati che la persona al palmare ha annotato quali sono i punti misurati agni due o tre misure, e comunque PRIMA di procedere ad altre misure.
  • Sequenza consigliate per le misure trasversali:
    1. Esegui le misure in croce della sezione della galleria (per es. i quattro angoli se la forma è rettangolare, altrimenti devi fare più misure. In Therion la stazione verso cui si misura è denotata dal carattere '-'.
    2. Dopo esegui le altre misure di ingombro: meandri a soffitto, approfondimenti nel pavimento, etc. Come sempre esegui due o tre misure alla volta e dai tempo al disegatore di fare gli schizzi di pianta e sezione longitudinale. Anche per questi il secondo caposaldo è denotato da '-' in Therion.
    3. Dopo esegui le misure agli elementi caratteristici: grossi massi, speleotemi, flussi d'acqua, ancoraggi, etc. Per questi il secondo caposaldo è indicato da un punto '.' in Therion.
    4. Per separare ogni gruppo si misure esegui una misura corta (20 cm) in orizzontale verso la tua mano). Questa serve alla persona al parmare per capire che inizia un altro gruppo.
  • Infine una sequenza di tre (o più) misure quasi coincidenti denota il tiro della poligonale. Dopodiché ti sposti sul caposaldo successivo.

Prendere le note col palmare

La numerazione dei capisaldi in PocketTopo

La logica di numerazione dei capisaldi di PocketTopo segue il metodo di Toporobot. Puoi trovare una descrizione alle pagine:

Il rilievo è suddiviso in “serie”, una o più per ogni sessione di rilievo. Ogni serie ha un numero (il numero di “serie”) che inizia con 1 e prosegue 2, 3, … Ogni serie ha la sua numerazione dei capisaldi; questa inizia con 0, e segue con 1, 2, 3, … Perciò il primo caposaldo della prima serie è 1.0, il secondo 1.1, etc. La seconda serie ha capisaldi 2.0, 2.1, etc.

Il caposaldo m.0 è usato solo se la serie comincia con un caposaldo che non appartiene ancora al rilievo. Altrimenti si usa il nome del caposaldo (che sarà n.x essendo di un'altra serie). La serie continua poi con m.1, m.2, …

Ogni serie viene memorizzata in un file separato, perciò usi Menu→File→New ogni volta che inizi una nuova serie.

Anelli chiusi e giunzioni in PocketTopo

Una serie non può formare (o contenere) un ciclo, perciò non può ritornare su se stessa. Questo significa che gli anelli sono formati solo allinizio o alla fine di una serie. In PocketTopo devi suddividere i rilievi in un modo simile e creare un nuovo file per ogni serie.

Le serie sono collegate tramite i loro punti iniziali e/o finali, cioè ogni serie può attaccarsi SOLO al punto iniziale o finale di un'altra serie, o a qualche punto intermedio. Una serie può anche iniziare e/o terminare senza essere attaccata ad un'altra serie (devono esser attaccate se fanno parte dello stesso rilievo, a mano di conoscere le coordinate di un punto anche nella serie scollegata). [Questa spiegazione mi sembra un po' confusa; da quel che ho capito, in Toporobot, una serie inizia anche in mezzo ad un altra, ma un anello non può contenre una sola serie.]

Ogni caposaldo ha un nome univoco in PocketTopo. Cioè, ad esempio, c'è un solo caposaldo 2.1. In Therion, al contrario i “survey” formano uno spazio dei nomi, per cui si possono essere due capisaldi differenti con “nome” 2.1 (in due survey distinti).

Come attraversare una 'serie' Come unire le 'serie' di un rilievo

Questo è il motivo per cui la serie 4 (gialla) tremina quando giunge al caposaldo 1.4 e continua come serie 5. Similmente dalla serie 7 (verde) alla 12, a dalla serie 8 (viola) alla 9.

PocketTopo on Trimble Recon

Il nostro Recon PDA è impostato in modo che

  • il soft button di sinistra ripristina PocketTopo, mentre quello di destra ripristina FileExplorer.
  • in PocketTopo, tutti i file (le serie) della stessa cartella si riferiscono alla stessa grotta. Le cartelle devono esser create nella root della struttura delle directory.
  • Nota che Recon (o PocketTopo) spesso mostra tutti i file recenti nella stessa finestra (diversamente dal comportamento tipico su un desktop/laptop). Fai attenzione.
  • Usa PocketTopo→Options→Smart per automatizzare l'assegnazione dei numeri ai capisaldi in modo incrementale ogniqualvolta ci sono tre misure simili consecutive.
  • Prima di niziare a rilevare usa PocketTopo→File→NewCave e (se cambi queste informazioni dopo che hai già fatto alcune misure, i nuovi valori non vengono associati alle misure già fatte; puoi modificarli però quando lavori con Therion):
    1. Annota il “prefisso” nei dati “Actual trip” di PocketTopo
    2. Imposta il primo caposaldo di ogni rilievo a 1.0, 2.0, etc.
    3. Annota i nomi dei rilevatori e i loro ruoli
  • Scrivi tanti commenti per i capisaldi e i tiri del rilievo: scrivi il caposaldo cui il commento si riferisce in quanto i commenti sono associati ai tiri, non ai capisaldi.
  • Nella finestra “Data view” se un caposaldo è selezionato, usa i bottoni '+' e '-' per cambiare il numero del caposaldo, piuttosto che la tastiera: è più veloce.
  • Se il disegno diventa confuso per sovrapposizione di un galleria su un'altra, usa PocketTopo.File.New: chude i dati precedenti e nasconde lo schizzo precedente in modo che tu possa iniziarne uno nuovo da capo. Se hai bisogno di modificare i dati precedenti in seguito, usa PocketTopo.File.Open (tutti i tiri degli altri rilievi appaioni in nero).
  • Misure con letture “rovesciate” sono molto semplici. In questo modo è possibile fare tiri anche con caposaldi “magnetici”, purché sia accessibile da due capisaldi su lati opposti della poligonale. Il solo problema, con Therion, è che bisogna usare il comando “extend” perché altrimenti la sezione longitudinale potrebbe non essere sviluppata correttamente.
  • Rilievo di passaggi laterali. (Questo punto mi ha confuso parecchio, e non credo di averlo rosolto ancora …). Seleziona il caposaldo da cui parte il rilievo del passaggio laterale (può essere sia un FROM o un TO). Usa ContextMenu.StartHere per iniziare una serie per il passaggio laterale. Inserisci una riga bianca in fondo alla tabella. Potrebbe esser necessario matter a posto i numeri, e devi aggiungere un commento per descrivere il nuovo ramo. Quando il ramo laterale è completato e vuoi continuare con il rilievo del ramo principale che è stato interrotto, selezione l'ultimo caposaldo del rilievo del ramo principale (sembra che deve essere un TO) e usa ContextMenu.ContinueHere. Una riga bianca viene inserita in fondo alla tabella, e la numerazione dovrebbe continuare dal punto in cui è stata interrotta nel ramo principale. Dovresti aggiungere una riga bianca.

Transferimento dati da PocketTopo a Therion

Devi assicurarti che il palmare comunichi con il PC. Nel caso del Trimble Recon e Windows XP, devi scaricare ActiveSync. Se usi Vista o Windows 7 i lPC probabilmente avrà bisogno di aver accesso a internet la prima volta che connetti il palmare, per scaricare i file automaticamente.

Il prossimo passo in genere rappresenta il punto 4 “inserire immagini di background” nella mia lista delle cosa da fare per il disegno quando fai un “rilievo senza carta”. Include esempi che seguono la mia convenzione per i nomi: naturalmente puoi usare il tuo modo per i nomi.

Ricordati di metter a posto tutti i commenti nella tabella e i disegni prima di trasferire i dati dal palmare (Vecchie versioni di PocketTopo permettevano la modifica dei disegni sono se usate su un dispositivo touchscreen).

Sezioni: capisaldi e tiri trasversali, visibili in PocketTopo non vengono trasferiti in therion (solo per versioni vecchie di PocketTopo). La mia soluzione è di ritracciarle nello schizzo, come fossero parte del disegno, e di etichettarle chiaramente, in modo che siano visibili in xtherion.

Apri PocketTopo ed esporta i file come segue

  • PocketTopo.File.Save: <Prefisso>-<NomeRamo>.top (file PocketTopo nativo)
  • PocketTopo.Export.Text: <Prefisso>-<NameRamo>Text.txt (non è proprio necessario, ma più facile da leggere che un file *.top o *Therion.txt. È il solo modo per leggere i commenti di capisaldi e tiri senza usare PocketTopo.
  • PocketTopo.Export.Therion: <Prefisso>-<NomeRamo>Therion.txt file di transizione a Therion

Ora usa questi file in xtherion

  • xtherion[Editor Window].File.New: <Prefisso>-<NomeRamo>.th crea un nuovo file Therion per i dati di poligonale
  • File.Import: il file *Therion.txt che hai appena creato. Questo inesrisce tutti dati di poligonale nel file therion appena creato. Devi aggiungere l'intestazione (e chiusura) del comando “survey” e tutti gli altri meta dati che ti servono.
  • xtherion[Map Window].File.New: <Prefisso>-<NomeRamo>[Pianta|Sezione].th2 crea un nuovo file Therion per i disegni. Nota che PocketTopo produce solo sezioni longitudinali non projezioni verticali.
  • Nel pannello 'Background Images' clicka sul bottone Insert, seleziona lo stesso file *Therion.txt. Questo crea un file xvi con i tiri del rilievo e i disegni. Puoi aggiungere più di un file xvi allo stesso file “.th2”. Il trucco per far ciò è di deselezionare la proprietà “visibility” per tutte le immagini di background prima di inserirne una nuova. Inoltre tutte le immagini vengono inserite nello stesso posto della Map Window. Sembra che per spostare una immagini xvi, devi deselezionare la “visibility per tutte le altre, e poi doppio-click e trascini l'immagine. Potrebbe essere che devi premere il bottone “Auto Adjust” nel pannello “Drawing Area” per poter accedere a tutti i disegni.
  • Aggiungi il prefisso del rilievo ad ogni caposaldo della poligonale con il comando (di Therion) station-names <prefix> [] nel file *.th. Questo ti risparmia tante battiture di tasti. Guarda la pagina Drawing Checklist > Scrap, per esempio “station-names AA” []

Per gli scrap tracciati sopra un file xvi i punti di tipo “station” prendono automaticamente il nome del capisaldo (opzione ”-name …“) dal file, con il nome usato in PocketTopo. Puoi far in modo che Therion aggiunga a tutti i nomi di capisaldi un prefisso ed un suffisso con la seguente optione del comando “scrap” ”-station-names <prefix> @<SurveyName>“. Per esempio (qui sono usate anche altre opizioni del comando “scrap”),

    \ -station-names AA @AA-EntranceSeries -author 2009.11.20 "B Mutton" -copyright 2009 "NZSS"

Questo non funziona quando lo scrap contiene punti “station” con differenti prefissi e/o suffissi. Capita di raro, o, almeno, dovresti cercare di evitarlo quando fai “rilievi senza carta”.

Una considerazione: forse un blocco tipo

  group 
  station-names [] []
  <refer to stations with no prefix or suffix>
  endgroup 

può esser usato per rimuovere temporaneamente prefissi e suffissi ?

AVVERTIMENTI

La declinazione magnetica non è trasferita da PocketTopo a Therion. Devi scriverla nel file .th manualmente, dopo il trasferimento dei dati, altrimenti la pianta può differire anche in modo considerevole da quella che si otterrebbe con le coordinate corrette.

PocketTopo memorizza con ogni misura la declinazione (e informazioni sul rilievo quali la data, i nomi dei rilevatori, etc.) impostate nel momento in cui arriva una misura, e tale associazione non può esser cambiata. Se in seguito cambi declinazione, o qualche altra informazione, ciò ha effetto solo sulle misure che seguono. La declinazione viene aggiunta all'azimuth delle misure per fare gli schizzi. Perciò se imposti una declinazione sbagliata e fai alcune misure, il disegno resta irrimediabilmente deformato.

Questo può venir utile quando vuoi che il testo nel pdf 2D della restituzione venga allineato correttamente quando la mappa finale è ruotata. Imposta la declinazione in PocketTopo pari alla declinazione più la rotazione. L'effetto è che lo schizzo xvi viene ruotato come la mappa finale, perciò l'allineamento del testo risulta in accordo con l'orientazione della mappa. La contropare è che le coordinate dei capisaldi memorizzati in PocketTopo sono completamente arbitrari. (Fino ad ora non ho prestato attenzione alle coordinate in PocketTopo - se accetti questo non penso ci siano altre complicazioni - ma potrei sbagliarmi).

Problemi nel trasferimento dei dati

Ho avuto (da inizio fino a metà 2010) problemi a causa di frequenti blackout di comunicazione fra il DistoX e il palmare Trimble Recon. Il DistoX di solito indica che ha una connessione BlueTooth (l'icona lampeggia) ma il trasferimento dei dati non ha luogo. Ci vogliono alcuni minuti prima che il trasferimento ricominci. Il livello delle batterie indica “pieno” in entrambi gli strumenti.

Ecco di seguito cosa abbiamo provato … e con che grado di successo:

Prova Risultato
Tenere gli strumenti vicini (1 m) Sembra non sortire successo
Gentilmente avvicinarli e allontanarli Come sopra
Ciclare fra le impostazioni Connect/Disconnect/Auto di PocketTopo Raramente successo
Spegnere e accendere il DistoX Successo occasionale
Salvare i file in PockeTopo Sembra l'approccio di maggior successo

Ho appena corretto un altro problema in cui il palmare non riconosceva la carta flash di backup, poiché era inserita nel posto sbagliato. Questo sembra aver migliorato la situazione anche se non ha risolto il problema completamente.

Ogni suggerimento sarà molto utile.

Ecco il suggerimento di Beat riguardo a come ripristinare una comunicazione bloccata. Continua a scendere nella lista (dei tiri) finché i dati non sono trasferiti. Attento che PocketTopo cerca di connettersi ad intervalli di 5 secondi; non essere impaziente. Se i due strumenti erano soliti comunicare puoi, quasi sicuramente, provare solo le prime due soluzioni:

  1. Di solito è sufficiente spegnere il DistoX per pochi secondi.
  2. Il passo successivo consiste nel far ripartire (warm boot) il palmare.
  3. Verifica che il DistoX non sia in modo “silent” (un piccolo “0” mostrato nella parte alta centrale dello schermo del Disto). Questo modo è attivato/disattivato con la sequenza di bottoni AREA, AREA, REF, REF, CLR. Quando il DistoX è in modo “silent” le misure sono memorizzate, ma non trasmesse.
  4. Se questo non basta bisogna verificare la connessione in altro modo. Prova a connetterti al DistoX con il Bluetooth manager. L'icona Bluetooth del DistoX dovrebbe lampeggiare: questo significa che il palmare “vede” il DistoX.
  5. Sconnettiti dal Bluetooth manager e prova a connetterti con PocketTopo (Menu:Bluetooth:connect). Se fallisce controlla che la porta COM sia corretta, cioè la stessa che per il Bluetooth manager. Se hai più di un DistoX, ognuno deve avere la sua porta, univocamente assegnata.
  6. Se la connessione ha luogo ma i dati non vengono trasferiti, prova a mettere il DistoX in modalità di calibrazione usando il comando del menù di calibrazione. Se il DistoX commuta in modalità calibrazione, vuol dire che i comandi possono anadare dal palmare al DistoX e la mancanza di comunicazione nell'altro verso è una anomalia. Ho sperimentato questa situazione con tanti dati memorizzati e attivare/disattivare il modo “silent” ha risolto il problema (ci ho messo solo 6 settimane a pensarci :-? ).
  • it/paperless.txt
  • Last modified: 8 years ago
  • by marco_corvi